Crash to desktop after making new landscape

Im very new to all this, and ive tried finding info on my problem but i cant seem to locate anything. Whenever i try to make a new landscape, specifically MI_newisland, it loads for a second then crashes right to desktop. No error pop up or anything. If i check the ‘fill world’ box, it doesnt do it. only when i try to do specific quad sets. Any help at all would be appreciated, im banging my head over this. Computer specs are nvidia gtx 970m, i7-5700HQ 2.70GHz, 16gb ram

Sorry I cant offer any help but I have pretty similar spec’d computer and I am having a tonne of stability issues as well. I however don’t just get crashes when importing a landscape it could be doing anything. Also once it has crashed I cant load my level back up without it instantly crashing. It would be interesting to see the logs to see what your issue is. They are located in the dev kit folder here:

For me I always seem to get the following issue for which after much searching I have been unable to find a solution.

Fatal error: [File:H:\SVN_Ark\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 653]
Rendering thread exception:
Assertion failed: IsInGameThread() [File:H:\SVN_Ark\Engine\Source\Runtime\Slate\Public\Framework\Application\SlateApplication.h] [Line: 166]

Computer Specs are Ryzen 7 1700, 16GB RAM and a GTX970

Im having the same problem as PixelMinnow and have no idea on what to do.

[2018.01.27-08.20.04:151][106]LogWindows: === Critical error: ===
Fatal error: [File:H:\SVN_Ark\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 653]
Rendering thread exception:
Assertion failed: IsInGameThread() [File:H:\SVN_Ark\Engine\Source\Runtime\Slate\Public\Framework\Application\SlateApplication.h] [Line: 166]

Computer specs: intel i5 7600k, 16GB RAM and a gtx 1070

I’m having the same problem as you guys, anyone know something about it ?

OK I think I’ve found where it came from
When I delete all Actors, it doesn’t crash anymore, so I deleted one by one until I worked, and the Actor that crashes my ARk dev kit is the Light source one… I don’t know why but it’s a start I guess.

Where do you delete them?

Where do you find it?

My ark dev kit keep close itself all the time… i dont know whats the problem

You open the ark dev kit, then on the upper right corner you have the “scene outliner” when you create a default map, you delete the actor “light source” then you can add the different mat to your new map, MI_Newisland etc… without having the ADK crashing, well at least it worked for me.

To resolve this, you do not need to delete the light source, just uncheck the “Atmospheric Light” setting.


Unchecking the Atmosphere Sun Light worked for me. Thank you , for this solution.

this didn’t help and now it just stay at 0% and doesn’t crash back to the desktop