Crash preventing editor from launching Hotfix 4.17.1 (on macOS Sierra 10.12.6)

I just updated to Hotfix 4.17.1 yesterday. Since the update, I can no longer launch the editor. I have tried to launch the editor from the Epic Games Launcher as well as straight from the Finder. The Editor doesn’t even start to load.

When I try to launch a particular project from the Epic Games Launcher, however, I can at least see the Icon for the editor appear in the dock as if it is trying to load. This happens for about 1-2 seconds before the editor icon disappears. A shame, since I really need 4.17 feature set to use ARKit.

Try launching it from the terminal:

cd /Users/Shared/Epic\ Games/UE_4.17/Engine/Binaries/Mac/

Hopefully that’ll output some useful info that will help narrow the problem down.

What Mac model and macOS version do you use?

Thanks. This error means that the editor couldn’t find Shaders directory, which should be /Users/Shared/Epic Games/UE_4.17/Engine/Shaders/

Could you check if you have it? Maybe something went wrong during installation? One thing to try would be to use Verify option in the Epic Games Launcher to verify the engine is installed correctly.

I ran the command. I receive the following:

Assertion failed: FPaths::DirectoryExists(RealShaderDirectory) [File:/Users/build/Build/++UE4+Release-4.17+Compile/Sync/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformProcess.cpp] [Line: 172]

So I ran the Verify. Not sure what was supposed to happen but it completed without event.
In regards to the existence of the file that is causing the failed assertion:
If what is being printed to console is supposed to be an absolute URL to the file then I can see this being an issue.

The file does in fact exist on my machine and the absolute URL on my machine is the following:
the unreal console output is asserting that the file exists here:


so it is checking in this non-existent extraneous folder called build in the Users directory.

Ignore the path to the .cpp file, this is where this file was when the engine was compiled.

The path it’s looking for is /Users/Shared/Epic Games/UE_4.17/Engine/Shaders/

Do you have it, are there any files in there?

There are three folders in this directory: Private, Public, and StandaloneRenderer.

The Private folder does not contain any files starting with GenericPlatformProcess.

I don’t know how to explain this based on the info you provided so far :frowning: If the Engine/Shaders folder exists, I don’t know why the check for its existence would fail.

Try this, please:

From Finder’s menu bar select Go->Go to Folder and enter

~/Library/Logs/Unreal Engine/Editor

This should open a window with log files from your attempts to run the editor. The newest one should simply be called UE4.log. Please attach it to this thread for me to take a look at.

I have uninstalled and then reinstalled 4.17.1 from scratch using the Epic Games Launcher and have the same issues.

link text

The Actual Editor is not generating any logs because it doesn’t even launch to the point where it can generate anything I suppose. But I have attached all of the most recent log files. Cookbook is a test project I had launched last before the update to 4.17.1

What about the terminal output when you launch it from the terminal. Is there anything there before this?

Assertion failed: FPaths::DirectoryExists(RealShaderDirectory) [File:/Users/build/Build/++UE4+Release-4.17+Compile/Sync/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformProcess.cpp] [Line: 172]

OK, thanks. That’s a different crash (obviously), so this is getting even more mysterious. The most puzzling thing is that 4.17.0 worked OK. I don’t have any good ideas at this point. One thing you could maybe try is to use First Aid in Disk Utility, as maybe there’s some permission issues with the UE4 folder structure. Or try restarting the Mac. It’s shooting in the dark, but considering the lack of better ideas, I think it’s worth giving a try.

There wasn’t the first time I ran it, but I just ran it again and got this,

link text

I will give disk first aid a try later. I restarted the computer with no luck. :confused:

Thanks for update. So weird. I’m very glad you made it work, though!

Had to remove all references of unreal from the system and reinstall. It works now. Now to figure out ARKit integration… Thanks so much for the assistance.

Hello there, I am experiencing the same issue. There is a Shaders folder in /Users/Shared/Epic Games/UE_4.17/Engine/, however it disappears as soon as I start the editor for some reason.

Hello sir, I have the exact same issue!