Download

Crash - out of video memory

I was hoping this will go away with ue5 but no, same problem as in ue4: when working on my laptop there’s 100% chance of editor crashing eventually with this error. Sometimes happens after an hour or two, sometimes after 15 minutes. Screen flickers black and my unsaved work is gone.
It’s really annoying.

I’ve read somewhere that unsaved changes are stored in video memory and cleared when saved to disk but that doesn’t make much sense, does it?

Anyways my laptop has 16 gigs of ram, gpu has 4. This problem never happens on my ‘better’ stationary rig. Is there a way around it?

Unreal crashes when your GPU is out of VRAM.
Go to Task Manager. Performance. GPU and look at Dedicated GPU Memory.
It fills your memory with textures when you open a level and doesn’t unload it. There is no garbage collection in Unreal Editor. Only way to free up your vram is by closing Unreal and restarting.

turn on texture streaming

is enabled

ok, I wonder if there’s a setting that would load them at lower resolution in editor (but not the one that limits texture size per asset…)

Navigate to (EngineInstallPath)\Engine\Config\ConsoleVariables.ini
open and on a new line enter:
r.MipMapLODBias=5
save and close, launch the editor.
This will execute the command every time you open the editor, the command tells UE4/5 to use a lower MipMap. Because its a bias, it will lower any texture by 5 MipMaps regardless of its size, 8K will go to 512, 2k to 64 etc, you can choose a different number to go up or down sizes.
To return to normal, just run the command in editor r.MipMapLODBias -1 or other numbers to view other bias, max is 14.
Do note the difference between the .ini vs the in-editor commands, ini uses an = sign, in editor uses a space.
As for unchanged saves affecting video ram, it has to keep those changes somewhere, and textures are stored in VRAM. If your base game has say 3.7GB VRAM usage needed, and you change 300mb+ worth of data, it will crash.

ok, thanks, I will try that

nope :frowning: everything is blurred as expected but still crashes and task manager indicates same vram usage regardless of setting

That’s odd, I use it to have low MIPS while editing and normal MIPS while playing and it works fine, changed on event begin and end play.

Mine goes from 4.8Gb to 6.5Gb. (shown in the black windows.)

You could just clamp the max texture size in the INIs, change everything I have selected in the file to say 2048 or lower.



I get this error any time i try to build reflection captures for my level. I do not know why… I literally have 2 RTX 3090s in NVLink… 24gb of ram each… Makes no sense since this project and its levle used to build in much older versions of UE4. Now its not a lightmap related bug… its a reflection capture build bug. What worries me is other people have complained about this even in 4.25… and no fix. Im thiinking the epic devs are more focused on new features then they are making their editor useable. Plus their new bug reporting system that replaced “Answers Unreal” … is dog ■■■■… You cant add to the bug what you have learned about it… if you report it.

disable one of the videocards… its a driver issue… it has been reported a bunch

how do you disable a video card? Seems silly.

Disabling card seems to work, unfortunately I had to disable dedicated one, unreal is really choppy on integrated but when I tried disabling integrated then whole system went choppy instead.

I’ve seen this error quite a bit working with UE4 with very large worlds, particularly when working with landscapes.

This sounds silly, but setting a fixed size on my page file seemed to resolve it for me (i only have 1 vid card)

Unfortunately this out of video memory error happens with 1 card and 2 cards… It is still occuring on unreal engine 4.27 beta… So… ■■■■ out of luck.