Crash on Startup (First Person Example)

After updating to 4.8, I get a full computer crash when creating and loading the first person example project (blueprint). The project fully loads and after 10-20 seconds of it being loaded my PC freezes completely. However everything seems to run fine if I create and load the third person example project instead.

Furthermore, I’ve tried opening the Kite demo project and the same crash happens. After of 10-20 seconds the screen freezes and goes to solid grey. I’m asumming the issue is somewhat related to projects that use first person.

Attached is the log from the crash when loading the Kite demo link text.

Hey Tachnew,

Can you send along your dxdiag?

Are you using any Oculus dev kits, by chance?

Can you go into your first person project folder, then go to the Config folder and open up DefaultEngine.ini. In there, remove the path for the “EditorStartupMap” and save it. Then re-open the project, create a new default map and tell me if it still crashes.


Thanks! Here’s the dxdiag

I’m not using any Oculus rift dev kits or have any VR related software installed.

I tried the edits to the DefaultEngine.ini and created a new default map. It took longer this time but I can confirm that the crash still happens.

I forgot to ask, but can you send me your callstack from the crashreporter window? You can just paste it into a txt file.


I get no crashreporter window unfortunately. The crash is a full PC crash. I get a solid grey screen and then it turns to black if I try to alt tab. I need to manually unplug the PC to reset it otherwise I can’t do anything.

I’ve tried retrieving a crash log from the location mentioned here but there’s nothing being dumped there.

Have you tried leaving the third person template open for a long period of time to see if it eventually crashes? I hesitate to ask you to continue hard crashing your computer just to test this. I’m going through some of the post processing options in the FP/3P templates and don’t see anything activated in the FP template that isn’t active in 3P.

Can you open up task manager and keep an eye on the UE4Editor.exe memory usage and let me know if it gets high?


Actually, yes. I’m getting the full crash on the third person template now as well but only when I was previewing a physics asset. I’ve checked mem usage and everything seems correct.

I’ve actually tried to alt + f4 after the crash happens and even tho nothing seems to happen, the log file from the session indicates that UE4 is able to close and shut down the project just fine? As if everything is still running even tho my screen is frozen/pure grey/black and I can’t see anything.

I did install 4.7 just to rule that any issues with my PC or drivers and everything runs perfectly there for all templates.

Does it consistently crash when you mess with the physics asset? I’m trying to narrow down the possible causes before contacting a specific engineer about this.

I’m unfortunately suspecting this could be a graphics card issue, but I’m going to try and see if there’s anything on our end that that we can do.

No, it just happens randomly after navigating the preview window of any asset after a while in the third person example. I.e a 3D mesh, a physics asset or anything else with a preview window. In the first person example it happens after 10 or so seconds after navigating the viewport. Whatever it is it’s not present in 4.7 as it runs fine 100% of the time there.

I had one of our programming support guys take a look at the log from your kite demo session. Would you mind creating a blank first person template project, letting it crash, and then sending the log from that? He’d like to compare the two

Sure. I’ve attached the log from the first person template project for both 4.8 and 4.7.6 just in case as well. As said the 4.7.6 version runs perfectly for me so maybe someone can track down what’s different there.

Also another related note, I’m able to run the runtime version of the Kite Demo perfectly as well. It only crashes when I try to load the editor version.

Quick question. Are you using source from github or a build from the launcher?

If you’re on source, can you try recompiling your engine code and if that doesn’t work, re-download and compile the engine code.

It’s the launcher version. I updated to 4.8.1 and nothing changed in regards to the crash. However I just updated the Nvidia drivers to the latest version released a couple days ago and that has fixed it.

It’s worth noting that I tried reverting my drivers and even performed a clean windows install before this and that didn’t fix anything. Not sure what triggered the fix since the change notes state that there have been no bug fixes in 353.30.

NVM. The crash has come back after I opened the editor version of the Kite Demo. Oh well.

Hey, sorry I converted this to an answer before this comment showed up. Do you have any hardware temperature monitors installed? If not, find whichever software you like (I find people typically use HWMonitor) and check what your CPU and GPU temps are.

Can you see if you have any of this software installed and active? A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums


I don’t have any of the conflicting software installed. I downloaded HWMonitor and I’m noticing no anomalous temperature reading for my GPU. Around 34-40ºC for my GPU and around 40-60 ºC for my CPU.

I’ve now reverted to a much older Nvidia driver, 335.25, and I’m 100% unable to trigger the crash now.

If I install the latest drivers, the process to trigger the crash goes like this:

  • Update/Install latest drivers.
  • Open First Person Template, no crash after long periods of time.
  • Open Kite Demo Editor. Crash after a while.
  • Open First Person Template, crash after random periods of time. Usually just a few seconds.

The crash goes away as soon as you update the drivers it seems. And it’ll come back as soon as the Kite Demo is loaded. The crash won’t go away if you plain reinstall the same version of the drivers or if you revert to a recent version tho.

Following the steps mentioned above won’t trigger the crash for my current driver version (335.25, before Gameworks and other features were added).

Well, I have no idea why the new drivers seem to dislike you (did you anger them?). Are you just in the default tutorial map in the kite demo or are you loading in the big level?

Either way, glad the older driver works for…reasons.


When I’m using the latest drivers I’m merely in the tut level, checking random assets. It’ll give me the gray screen after a while by just doing that. If I try to open the big level it’ll freeze out, no grey or black screen, just frozen screen as if the level is taking its time to load mormally but after a while it’ll grey out too.

I’m assuming that since the Kite demo is very resource heavy, something in the newest drivers struggles to handle the writting of cache data and since the PC is being reset in the middle of that process then some sort of file or mem corruption is happening that seemgly propagates to every other UE4 project loaded afterwards.