Crash on startup after adding variable to struct

I have a few custom structs in use in my project, referenced in blueprints, parent blueprints and child blueprints. After adding a variable to a struct that was in use, I started noticing startup errors. This could be rectified by trying to open the project again, 2 or 3 times. Yesterday (and again during testing today) I added a variable to a struct, and can no longer open the project - it crashes on startup. The only thing i can think of that was different this time is that the struct that was added to is the first to be referenced by a blueprint that has child blueprints.

The crash report is attached link text. It seems to mention the blueprint compiler. This is a bit of a showstopper - I’m going to need to be adding new variables to structs throughout the project. While waiting for support I’m going to try and duplicate the struct, add the new variable and then update each of the nodes to see if the issue still occurs.

version is 4.9.2. Issue was occurring on 4.9 so I updated to 4.9.2.

Update: Attempting to delete using the ‘replace references’ option, or just using ‘replace references’ by from asset_actions now causes a crash as well. Really stuck here.


I have a few questions regarding your issue:

  • Have you attempted to open the project in 4.10?
  • Can you reproduce the issue in a clean project?
  • When the crash reporter window appears, could you copy your Machine ID and post that?
  • Finally, ensure that you press Send on the crash reporter window when it appears.

Thank you.

Hi Sean,

I havent tried the project in 4.10, I’ll download that and try it today.

Not sure how I’d reproduce this in a clean project - the issue seems to be bundled up with the struct and blueprints I’m using in this project - plus it’s this project in progress i need to get working moving forward.

Machine ID is 7D14BD9646D9077027D559BF94ADD547, and the crash report has been sent.

Thanks for your response!

From what I can see based on the crash report, this seems to be a project-specific issue. Definitely give it a shot in 4.10. Also, if you could zip up your project and upload it to Dropbox and provide me with a link, I could attempt to identify the issue. Thank you.

Hi Sean, I’ve narrowed down the issue and have links to .rar archives or working states and broken states of the project. I’ve PM’d these to you on the forums. I’m also in the process of installing visual studio 2015 so that I can test with UE 4.10

The repro process is as follows:

  1. Open the working project (you might have to hit ‘send and restart’ once or twice to get through existing crashes, but it eventually opens).
  2. Add a tropical_good reference to news_item_struct. I’ve tested adding a user widget and a bool, and it doesn’t happen with them - only the tropical_good reference.
  3. Press ‘play’ to get the engine to recompile all blueprints, once it does this the game will launch fine (which is whats confusing me).
  4. Save and close the project.
  5. Try to re-open the project. From now on, it will crash on startup everytime.

I’m confused as to why it works in-game, but then crashes on startup each time.

I thought it may be a circular reference, but I dont understand why it works in game if thats the case: there are multiple tropical_goods, and each has a tropical_good_consumer_market which it saves as a variable reference. Each tropical_good_consumer_market also saves a reference to its parent good. My aim was to add this parent_good reference to a news item struct - so the news_item_struct is referenced at the end of one of the tropical_good_consumer_market’s functions. This shouldn’t cause a loop should it?

Thanks for looking into this.

I have been able to reproduce the crash in the project you’ve provided. Have you had the chance to try the project in 4.10, and if so, were you still experiencing the same issue in that version?

Yes I tried it with 4.10, and unfortunately the same issue occurred.

After spending some time looking into the project, I haven’t been able to nail down exactly what is causing the crash. The project by itself crashes at least 3 times before opening successfully, and the project itself seems to have 3 unique crashes occurring in it.
My advice for now would be to attempt to migrate the assets into a clean project one by one. This way, when you begin to experience the crash you will be able to nail down which assets seem to be causing the issue.

Thanks. For now I’ve worked around the issue by using a string variable in the struct instead which doesn’t seem to break it. I’ll try the clean migration when I get a chance.