Crash on saving my Persistent Level

The editor crashes when I save my Persistent Level. Any help on how to investigate this would be huge!

I have recently upgraded from 4.5.1 to 4.7.3. I’ve included the editor and crash reoporter logs.

I reverted the map to an older successful save. It still crashes.

It also crashes when saving other unrelated maps.

I was able to start a new project and save that map. I’ve tried disconnecting from source control. I’ve tried replacing the project config with 1st person BP template config. It also crashes on Save All, in which case I don’t see the check out files dialog. I can save other assets individually.


If you pull the contents folder out of your project and then re-open and save, does the crash still occur?

I don’t quite understand. The levels are in the contents folder. Do you want me to remove all other content, then open the level full of missing things, then save?

sorry I meant pull everything except the maps/levels out. I want to see if the crash is coming from a specific object within your contents folder or if your maps/project is corrupt. More than likely a specific blueprint/object is causing the crash and this will help narrow down what is being looked at.

Great idea, !

I made a backup project to mess around with. I pulled out my main folder of blueprints, opened the level (ignoring the warnings) and was able to save. I then brought them all back in but the most recently modified ones, and it still saved. More elimination revealed the single blueprint that, once removed from the level, let me save the level. After the level is saved once, you can bring the blueprint back, restart the editor, and return the blueprint to the level manually, and it will continue to save as normal.

Thanks for your help!



After several successful saves, eventually my computer froze during an autosave (this might actually be my CPU overheating, but it doesn’t matter) and the next time I opened my map, the level would crash on save again. I think I recall a freeze during an autosave last time this crash started, in fact.

My question is, is it possible that an interrupted autosave could corrupt one of my blueprints? Could that be a fixable bug?

While it is possible, what is more likely is there is something within the blueprint that is causing the error. Can I see a screenshot of the blueprint event graph?

Looks like there’s some corruption in the custom struct I made called Palette. If I refresh the node, the garbage text does away, but the crash doesn’t.

try deleting and recreating the node, Does this occur with a new struct as well or does this error only occur with this struct in particular?


We were able to reproduce this on our end and have entered a bug report, UE-12550 to be assessed by the development staff.