Crash on Play in Editor after certain amount of time

So I’ve been plugging along rather well and now I’m getting an odd issue. I’ll start up the editor, do my business, playtest the game, etc. Without fail, after the tenth-or-so time I open the game in the editor to test it, the editor crashes. No crash log, it just shuts off. I can’t be sure whether this happens after a certain amount of time spent in the editor or in the game itself, but it only crashes while the game is running.

Right now this is just a minor annoyance – it takes less than 20 seconds to open the editor right back up, but the project is still in very early development. Once it becomes more complicated I expect it will take longer and longer to get it open again.

I have no idea how to debug for something like this.

Here’s the saved log from one such crash, if it helps. In this particular case, the crash occurred just a second after running the game.

Staff Edit: pasted log removed, .txt created and attached.link text

Hello Cinebeast,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved?
  4. When your project crashes, does the engine actually shut down on it’s own or does it freeze up?

I can answer #4 right away – it freezes up for a half second, then a little “this program isn’t responding” window pops up, and it shuts down.

By “clean” project do you mean something made from a template, with no additions of my own? I’ll give that a shot.

I really have no idea which blueprints could be causing an issue, but here’s part of the blueprint I was working on when the crashes started to happen. This was my attempt to receive stimuli for an AI using the AI Perception component.

I’ve tried using a Pawn Sensing component instead, but the crashes still occurred, so I don’t think this is the source of the problem.

Thank you for the help.

Okay, I created a clean project and could not reproduce the problem. I left the project open all day, periodically checking in to playtest it, and it never crashed.

I also tried making a copy of my own project, but this eventually crashed as well. Next I’ll try deleting some things in the copy, in the hopes of narrowing down what, exactly, is causing the crash.

I do think it might have something to do with the AI I’ve been working on, because I have yet to experience a crash while working on a level that has no AI actors inside it. But I still don’t understand why the crashes occur so rhythmically. It feels like I’m allotted a time limit every time I open the project.

Hello Cinebeast,

After you have narrowed down what is causing the issue in your copy, please update the thread with that information and I will be happy to assist you further. To answer your question about the clean project, what I meant was for you to recreate the asset/situation you thought was causing the crash in a clean project (so that a reproducible test case could be produced).

I see. I’m not sure how to do that, considering there’s a lot of stuff in the project, and any number of tiny differences might make it or break it. I’ll try.

In the meantime I made a copy of the project and cut everything related to the AI – the behavior trees and the controller, etc. – because I was thinking those could be the source of the issue, but the project still ended up crashing in the same way. I don’t know what else to cut, since the crashes didn’t start to occur until after I’d implemented those things.

Thanks again for the help.

Hello Cinebeast,

Would it be possible for you to zip down your project and provide it via drop box or google drive?

I think so. I’ll start the process.

In the meantime I made a clean project and started migrating the project in one set at a time (player character stuff, then AI stuff, etc.) and weirdly, I haven’t had any crashes. This makes me think there could be some problem inherent to the original project. I wonder if I made a brand new game and simply migrated everything I’ve made into it, would the problem disappear?

Here’s a link to the zipped project on Dropbox.

I downloaded the project and tried to reproduce the issue on our end. However, after running a few tests based on the information you gave about how your project crashes, I was not able to get the project to crash. Could you try downloading the project from the link that was provided and let me know if you can reproduce the crash on your end? If so, could you then provide the steps needed to crash that version of the project on our end?

Good idea. After testing it for about half an hour, it crashed. All the while I treated it like it was the original, playing around with values in the player character and the AI. Fiddling with the character’s jump velocity, damage output, adding a few print strings, etc. Here’s the log, in case it helps.

I also booted up the duplicate project I mentioned in my last comment and did the same, and it also crashed.

After looking around on the Internet, I’m thinking this might have something to do with the way I’m using child blueprints. Both the player and NPC characters inherit from one blueprint, and all of the breakable objects inherit from their own as well. Some people have mentioned they got crashes when changing variables on a base actor while that actor has a child instance in the loaded map, and that the problem might be alleviated by removing those instances from the map while editing their parent.

That’s my wimpy little guess, anyway.

EDIT:
Oops, here’s a link to the page I mentioned.

Thank you for the additional information, however I am still unable to get your project to crash on our end. Do you have a more exact set of steps that you can give that reliably cause the crash that you are seeing?

Thanks for the suggestion. I don’t think there is any surefire set of steps that cause the problem, but I went through anyway and kept a log.

All I did was change some values at random and do a few things I’d normally do, like adding an event or two. In addition to keeping up the log, this took about half an hour before the engine crashed.

Hello Cinebeast,

I have not been able to reproduce this crash on our end after much testing. could you try deleting your saved, intermediate, and config files and then upgrade your engine version to 4.11.2 and let me know if the crash is still occurring? Please note that you may want to make copies of any folders deleted so as not to lose any back up files.

Hello Cinebeast,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.