Crash on level change

Hey guys,

i have had no issues with the editor however when i package my project and do a level change from any to this one in particular it crashes with the following error, could you help me with this please? Mac os 10.12, UE 4.12.5

MachineId:F7D975922D4AAB8C984673B35997C768
EpicAccountId:fc21edde7a084948aa43f1abdb33ffac

 SEGV_MAPERR at 0x3

FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x10f8fc74b (filename not found) [in UE4Editor-Core.dylib]
FOutputDeviceMacError::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x10fa9e4e6 (filename not found) [in UE4Editor-Core.dylib]
FOutputDevice::Logf(wchar_t const*, ...) Address = 0x10fb55f27 (filename not found) [in UE4Editor-Core.dylib]
FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x10fb514c4 (filename not found) [in UE4Editor-Core.dylib]
___ZN17FMetalCommandList6CommitEPU27objcproto16MTLCommandBuffer11objc_objectb_block_invoke Address = 0x13cdbcbba (filename not found) [in UE4Editor-MetalRHI.dylib]
_doMTLDispatch Address = 0x7fffc73b937e (filename not found) [in Metal]
-[_MTLCommandBuffer didCompleteWithStartTime:endTime:error:] Address = 0x7fffc73ba405 (filename not found) [in Metal]
-[MTLIOAccelCommandBuffer didCompleteWithStartTime:endTime:error:] Address = 0x7fffc7386669 (filename not found) [in Metal]
-[_MTLCommandQueue commandBufferDidComplete:startTime:completionTime:error:] Address = 0x7fffc73be52a (filename not found) [in Metal]
__53-[MTLIOAccelCommandQueue submitCommandBuffers:count:]_block_invoke.27 Address = 0x7fffc739ad01 (filename not found) [in Metal]
ioAccelCommandQueueBlockFenceCallback Address = 0x7fffd25c98cc (filename not found) [in IOAccelerator]
IODispatchCalloutFromCFMessage Address = 0x7fffc5bde028 (filename not found) [in IOKit]
_IODispatchCalloutWithDispatch Address = 0x7fffc5bde0a7 (filename not found) [in IOKit]
dispatch_mig_server Address = 0x7fffd8cb9668 (filename not found) [in libdispatch.dylib]
_dispatch_client_callout Address = 0x7fffd8cab128 (filename not found) [in libdispatch.dylib]
_dispatch_continuation_pop Address = 0x7fffd8cc0c10 (filename not found) [in libdispatch.dylib]
_dispatch_source_latch_and_call Address = 0x7fffd8cb6ad2 (filename not found) [in libdispatch.dylib]
_dispatch_source_invoke Address = 0x7fffd8cad966 (filename not found) [in libdispatch.dylib]
_dispatch_queue_serial_drain Address = 0x7fffd8cc19d2 (filename not found) [in libdispatch.dylib]
_dispatch_queue_invoke Address = 0x7fffd8cb3d41 (filename not found) [in libdispatch.dylib]
_dispatch_root_queue_drain_deferred_item Address = 0x7fffd8cc23bf (filename not found) [in libdispatch.dylib]
_dispatch_kevent_worker_thread Address = 0x7fffd8cc51b0 (filename not found) [in libdispatch.dylib]
_pthread_wqthread Address = 0x7fffd8ef761f (filename not found) [in libsystem_pthread.dylib]
start_wqthread Address = 0x7fffd8ef7221 (filename not found) [in libsystem_pthread.dylib]
Unknown() Address = 0x70000b934b40 (filename not found) [in ???]

Thank you!

Hi Playrok,

Just to make sure I understand the description of when these crashes occur:

This happens specifically after packaging a project and when you switch to a specific level in the editor. In other words, if you open the project in the editor and change to the level in question without packaging, the crash does not occur?

Are you able reproduce this in one of our Sample Projects and provide repro steps? If not, can you describe the closest template project so we can try to reproduce this on our end (ie. Blueprint Third Person vs. C++ first person…)

Lastly please provide as many of the following as possible:

Your Mac’s specs. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary).

The “System Report:” Apple menu >About This Mac > System Report>Hardware (All information listed in the “Hardware Overview.”) You can cut and paste this information or provide screen shots, whichever is more convenient.

The UE4.log (Located: ~/Library/Logs/Unreal Engine/Editor/)

The ProjectName.log (Located: ~/Library/Logs/Unreal Engine/ProjectNameEditor/)

Providing this information and appropriate logs will help us track down and isolate the source of the bug as quickly and efficiently as possible.

Thanks for your cooperation,

Steve H.

Hey Steve,

absolutely, everything is included below. I have also tried the compiled demo on 2 other macs, one also being an imac but an older generation (2011) and a macbook pro. Macbook pro did not seem to have any issues however the Imac crashed, same as mine.

And yes, editor is fine, only the compiled demo. I did not use sample projects however did import Koolas snow project assets and made the level (for a uni project on sound) using them
link text
link text

link text

Hi Playrok,

After examining your game log, I found the following error:

The following AnswerHub addresses this issue: [Reallocating scene render target constantly. Why?][2]

So, if this is indeed the same error, this has been fixed in UE4.13. However, if you want to remain in 4.12, The only known work around is to lower the render target size below 700 x 700. In the screenshot below it is set to 512 x 512:

Steve H.