Crash on launch on Mac

Installed UE4 on my Macbook Pro, crashes on launch.

Specs of Laptop

Macbook Pro Retina 13" (Late 2013)

128GB SSD

4GB RAM

Iris graphics (1.5GB)

OSX Yosemite fully updated (as of 4th January 2015)

I’ve tried 4.6.1, 4.5.1 and even the 4.7 preview.

The log is the same for each version. It appears to not be able to create an OpenGL context.

Pastebin of the minidump UE4 crash - Pastebin.com

Hi Sudorossy,

How far do you get before the crash occurs? Are you trying to open from the Launcher or have you compiled from source using GitHub? Are you able to get to the Project Browser to create a new project, or does it crash before then?

Please copy/paste the information from the Apple Menu > About This Mac (minus the Serial Number). Thanks!

Hi Ben, thanks for the reply.

I open from the launcher, on clicking “Launch” either from the main screen or from “Library”, the launcher minimizes and a second later the crash log comes up.

I can’t create any projects.

Info from “About this Mac”
OSX Yosemite
Version 10.10.2
MacBook Pro (Retina, 13-inch, Late 2013)
Processor 2.4 GHz Intel Core i5
Memory 4 GB 1600 MHz DDR3
Graphics Intel Iris 1536 MB

Currently my Display options are on “more space”, but I get the same error if I leave the display options on default.

Please zip and attach the logs found in this location:

~/Library/Application Support/Epic/Unreal Engine/4.X/Saved/Crashes/CrashReport-ProjectName/

Note that /Users/yourusername/Library is invisible. While in the Go menu, hold the Option key and select Library to open it in a Finder window.

Here’s the attached crash reports. There were a few folders in that folder (I assume from the multiple times I’ve started the program), so I zipped them all.

10.10.2 is a pre-release build, nothing has been tested against it, but even then that’s an odd error to be seeing. It suggests that OpenGL can’t create the context, but I can’t reproduce that here on my machines.

As a first step if you can try running 10.10.1 (the current public build of Yosemite) just in case it is a 10.10.2 issue.

Thank you! I had no idea it’d kept updating to beta versions after Yosemite released.

This solved my launch issue. Thanks again.

Installed completed … When I clicked launch on Epic Game Launder, it crashes right away. I need help with this. Thank you.