Crash on launch? Failed to open descriptor file

I’m able to run the project I’m working on when I cook it for mac, but it keeps hanging when it’s installed to my phone.

I’m very new to UE4 and I’m getting two errors so I don’t know which one is causing this… on the output log i’m getting
MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_2fc5b_0///////STATCAT_Advanced//// old //STATGROUP_Threads//FLauncherTask///Thread_16e0f_0///////STATCAT_Advanced////

On the phone it seems everything installs and at the splash screen i get a popup with the error: Failed to open descriptor file ‘…/…/…/samplegame/samplegame.uproject’

For the first error all my searching turned up that there might be threads with the same name, but this happens for every project I try to run, sample projects, blank projects with no starter content… everything.

The second error that i get on the phone people suggest making sure you’re not running two instances of UE4… i’ve verified that I’m not.

My mobile provisions show valid…

I’m stumped, any help would be greatly appreciated.c7cdedfbcca8a94ddb8e1dad181c78cd2b52c173.png

Crash on launch most likely has nothing to do with your provisioning profiles. Typically a provisioning profile error will prevent installation in the first place. I’ve seen rare cases where it will let you install, but not launch the app, but it doesn’t usually crash, it gives you an alert saying it can’t be launched.

If you have Xcode, plug in your device and go to the Devices window. Find your iPhone or iPad and look through the crash logs and see if there is one. If there is, paste it in here - that will tell us what crashed. If there’s no crash log, try launching the app, then expand the console view at the bottom of the Hardware window. You should get a bunch of messages from the OS and/or your app. Those should give a clue about the problem.

I’ve seen crash on launch cased by [FONT=Courier New][MTLTextureDescriptor validate] fail on builds with Metal enabled. You can also crash from low memory on launch, especially with older devices, but if you’re getting this with a fresh project, it’s probably not that. There are any number of other things it could be, but without the crash logs or device console logs, there’s not much we can do to help.

Hey Jeff, I’m starting to think it doesn’t crash, since I couldn’t find any crash logs in Xcode, just merely hangs at the splash screen… I’m attaching the logs for when i package the project and when I launch it, hopefully it’ll provide more insight as to what’s going on.

How are you running it? Are you creating a package then installing it directly on your device, or are you running directly from the UE4 Editor using “Launch on Device”? If you’re creating a package, are you doing it from Xcode or from UE4? It looks, from the log, like you’re doing Launch on Device.

So, I’m not seeing anything obvious in the log. The warnings at the end of your log happen in many of my projects and don’t seem to affect the ability of an app to run.

It’s clearly finding your provisioning profile and appears to be signing the executable.

Some things to take into account:

Launch on device only copies the current level onto your device. If you do map switching, that almost certainly won’t work.

On 4.7 and earlier, if you build or run from Xcode, it doesn’t actually include any game content, it just includes the binary. For debugging, it will connect to UE4 and pull down the content it needs… in theory. I’ve never gotten it actually working and have never found good documentation of the process. I’ve been told 4.8 makes the process of debugging from Xcode easier, so fingers crossed that it is, or that somebody at Epic bothers to document the process better for us.

Have you considered putting some debug messages (addOnScreenMessage from C++ or Print from Blueprint) in BeginPlay on an object that loads automatically in the level?

I wish I had more helpful suggestions, but nothing jumps out at me from the log.

Hey Jeff, been kind of busy but still hoping you could help me out… had a bit of a new development… I’ve always just searched for the *.ipa when i was done packaging through finder, after reading the documentation apparently it’s supposed to put the ipa in the [game name]/IOS directory… and it’s not doing this even though it’s showing up as packaging successful after it’s done… so my problem (all along?) has been it’s not packaging an an ipa file, since as you said just launching it doesn’t compile the whole file… I’m attaching my packaging log, hopefully you see whatever is going wrong in there. As far as I know the documentation says it’s supposed to create an ipa file that i’m supposed to install from iTunes… it never creates one in [Game Dir]/IOS but there’s one in [Game Dir]/Binaries/IOS, and when I install that one via iTunes it still hangs.

As for my project for this build it’s one barebones level with just a floor, I’m going to try adding this commands you talked about in blueprint to see if i can get something from the console when I run it.

How are you packaging and what distribution profile are you using (DebugGame, Development, Shipping)?

When I package a project, it prompts me for the directory, and then it does put the resulting IPA inside a folder based on platform. I never go directly into the [Game Dir]/Binaries folder, though if you’ve done a full cook and package, what’s there should, in theory, be your app.

How big is the final .ipa file? Even with just the template content, it should be fairly large… 75-100 megs. My guess is you’re getting an incomplete app - one without the actual content cooked into it - but it’s hard to say. Could be any number of things going on. Nothing jumps out from the build log, though.

Hey Jeff… here’s my update for you, normally I was using the development profile… but I tried switching to shipping profile and noticed the ipa got bigger, 59.5mb on development vs 88.5mb on shipping. When I try to run and install the shipping ipa I actually get a crash log. From the device it’s just the dreaded SIGABRT

I tried loading up a demo, tappy chicken which i figured would work and I could use it to make sure it wasn’t something I was doing. Oddly enough, same problems with it, doesn’t create ipa’s where it’s supposed to, only in the /Binaries/IOS directory, and the ipa’s are the exact same size as my blank project, 59.5 for development and 88.5mb for shipping, so something definitely isn’t getting cooked right.

I followed the directions here to uninstall UE4 completely, then reinstall it, but I’m having no luck stopping this from happening.

There any way I can escalate this problem to anyone at unreal to get them to look into what’s going on? It unfortunately seems like a program error at this point. Barring that, I’m just going to list how my system is set up and maybe you’ll see what’s wrong? Working on a 2012 retina macbook pro, running OS X yosemite, Xcode 6.3.2 installed with command line tools (which i read UE4 needs). I’m following the quick start guide of cooking then packaging for iOS (and yeah I get the popup of where i want to put the IOS folder with the packaged project, but no matter where i select, the folder ends up empty).

Only other thing I can think of is to post a zip of my entire uproject (minus the provisioning profiles) and see if you can cook / run it and see if it’s some file UE4 isn’t creating?
ETA: I’ve been watching some video’s of people working on projects with unreal engine, and it seems a problem with my projects is that it’s not generating any info.plist’s… they’re supposed to be generated automatically from what I read in 4.7+ in the /Build/IOS folder or even Intermediate folder… I tried the fixes posted for 4.6 of renaming the project in project settings then renaming it back to have it generate them, but that doesn’t work… really don’t know what’s up with my install of the engine.

That’s all I’ve got for now, thanks again for all your help!

If you want to post it, I’d be happy to look. I know it definitely doesn’t use the Info.plist file in 4.7, because our project as been migrated all the way from 4.1. I’ve updated the info.plist and the changes did not roll into the app (Additional Plist Data: in packaging settings works, though)

Sorry, missed this on my first read. Did you file a bug report on AnswerHub? That’s the best place to get Epic’s attention. They typically respond to bug requests promptly, though they’re heads down getting 4.8 out the door so it may be slower than normal.

Haven’t made a bug ticket on answerhub yet since I kept thinking it was something I was / wasn’t doing. Here’s a link to a project I have, let me know if it lets you install it to a device, or if there’s any necessary files missing or anything you come across that might help me figure this out, thanks!

https://www.dropbox.com/s/jid0f83gmigts7q/samplegame.zip?dl=0

Yeah, it builds fine for me. :frowning:

hi Jeff, I am getting the same issue. I was testing a vehicle project made for desktop as target.
When i ran it on iPad, i got horrible FPS. Then i changed settings in Project Setting, with Target set to Mobile and in rendering i turned off Mobile HDR.
It asked me to restart the editor.
After i restarted the editor, On using ‘Launch’ i got the same error as forgets.
And it has been like that since then. What can i do?

UPDATE :: I just restarted the editor and it worked fine.

Kinda funny. But m glad that happens.