Crash on Launch [4.0 - 4.2]

Hey guys,
so im having the same problem as many people have been having before.
The Editor will not load, I’ve tried starting the Editor from the Launcher, and by the .exe itself, nothing works.
I even compiled the Editor from Source, still not working.

I exceed the minimum requierments. (dxdiag attached)
Since this question was asked before I looked through most of the previous asked questions,
but most of the poeple had NVIDIA graphics cards, and could fix their issue by forcing the editor to use the proper GPU
instead of onboard stuff, I can’t do that unfortunatly since i have an ATI.

This is the Error Message I receive from the Editor itself:


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: ModuleInfo->Module.IsValid() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.2\Engine\Source\Runtime\Core\Private\Modules\ModuleManager.cpp] [Line: 609]
Tried to use invalid module …//…//…//Engine//Binaries//Win64//UE4Editor

KERNELBASE + 37901 bytes
UE4Editor_Core + 2998748 bytes
UE4Editor_Core + 1620298 bytes
UE4Editor_Core + 1561376 bytes
UE4Editor_Core + 1790045 bytes
UE4Editor_Engine + 6083621 bytes
UE4Editor_Engine + 8033626 bytes
UE4Editor_Engine + 7938563 bytes
UE4Editor_Engine + 7946584 bytes
UE4Editor_Engine + 7948124 bytes
UE4Editor_Engine + 8063387 bytes
UE4Editor_CoreUObject + 1051976 bytes
UE4Editor_Engine + 14490367 bytes
UE4Editor_CoreUObject + 1051976 bytes
UE4Editor_CoreUObject + 1543526 bytes
UE4Editor_CoreUObject + 1580504 bytes
UE4Editor_CoreUObject + 1607153 bytes
UE4Editor_CoreUObject + 1626749 bytes
UE4Editor_UnrealEd + 1071414 bytes
UE4Editor_UnrealEd + 1083936 bytes
UE4Editor_UnrealEd + 1133227 bytes
UE4Editor_CoreUObject + 349666 bytes
UE4Editor_CoreUObject + 1632972 bytes
UE4Editor_CoreUObject + 1585586 bytes
UE4Editor!FEngineLoop::PreInit() + 10377 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launchengineloop.cpp:1225]
UE4Editor!GuardedMain() + 236 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launch.cpp:111]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:207]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

I hope this problem can be fixed soon, since I’m a student, paying for a subscription to an engine which doesn’t work,
isn’t really an option for me.


Hi Stockbrot,

Sorry to hear that you are having an issue getting the editor to run. First, have you made sure that you have updated drivers for your graphics card?

If you are updated, and you are still crashing, then we will need some additional information to try to troubleshoot this.

C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs

Please attach the latest log from this location

Also, use the Marketplace to download a sample such as Content_Examples if you don’t already have it. Then click the “open” button next to it to load the project directly. You will probably still crash, but then also provide us with the log found here:

C:\Users*username*\Documents\Unreal Projects\ContentExamples\Saved\Logs\ContentExamples.txt

You can put both logs into a Zip file and attach it here.


Thanks for your quick response!

Yes I’m using the latest drivers for my graphics card, I’m currently downloading the newest Beta drivers to give them a try. (AMD CCC 14.6 Beta)

here is the logfile from the Crash Report Client

and here is the logfile from the Content Examples

Thanks aswell :slight_smile:

I will upgrade to Windows 8, to see if that helps the case

I seem to have fixed the Error by installing Windows 8.
(I can start the 4.1.1 compiled version (Windows7), currently downloading 4.2)

As I have found out through a friend, my Windows was pirated (it was from a friend, who said put a legit one on there).
Maybe that was the Issue?

Here is my newest dxdiag file.

Allthough my problem was fixed, it could still mean the problem persist for other people.

But I’m guessing it had something to do with my OS Version.

Glad you managed to get it resolved. Yes, you probably had missing or corrupted DLLs on your system. Doing updates or reinstalls of the specific software which made the DLLs (or an entire Windows reinstall) would be the best solution.