Crash on importing FBX animations

Hey guys,

Currently in 4.10 I seem to be unable to import animations, the editor crashes through anything I try. I retried in 4.9.2 and it worked, so it seems something broke in 4.10.
Steps to reproduce:

  • Make 3rd person blueprint project.
  • Import fbx file into project.
  • Make sure import animations is selected.
  • Import and crash.

The file I’m using includes both the model and a base animation(It’s the default Beta model from Mixamo). If you don’t import the animation with the model, it doesn’t crash, but as soon as you try to import any separate animation onto that skeleton separately the editor also crashes.

Hello BattleSpunk,

If you would provide the .fbx that you are having the issue with, along with the animation, I will attempt to recreate this issue on my end.

I am also having this problem in editor 4.10 FBX Test
Crashes on animation import. (inside is the Beta char and one anim)

I’m reverting to 4.9.2

Hi , here’s the files in question: link

This appears to be a bug as I am able to reproduce this issue. The curious thing is I am able to import an animation and mesh from Maya to Unreal 4.10 and I do not see the crash happening.

I have entered a Bug to be reviewed by our development team.

The ticket number is UE-23324.

Thank you very much for reporting this issue to us.

FYI, i saw that this was fixed in perforce and pulled it down and was able to import the animations that were crashing. But, if I deleted the assets and set my animation compression scheme to automatic in the project settings, it would again crash importing the animations in a different spot though.

Edit - FYI when i say set my animation compression settings I mean go into my project settings and set the default animation compression to automatic.

I am still seeing this crash trying to import fbx files that worked fine on 4.9.2. I have the latest UE4.10.1 available in the Epic Games Launcher.

Hey guys,

This issue is flagged as being actively worked on. I still do not have an ETA for when this issue will be resolved or for what release this will be made available.

Thank you for your patience,

Is there a workaround? Sounds like a compression problem? I’m not able to import any animations at all, so we really can’t start using 4.10 or 4.11.

You should be able to import your models with animation enabled into 4.11. Would you set up a test with a clean blank 4.11 project and see if you are able to to import without the crash?

I have verified this is fixed as of the latest version of 4.11.

Hello, I am facing the same issue, May i send the file here? So that you fix it, btw I purchased it

I will try iporting it in ue4.11