Crash On Heightmap Import 4.12

Everytime I try to import a heightmap, the editor crashes. Below are my settings. The file is a png. This has worked in the past, and now it just doesn’t.

Hi StealThyPie,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • What is the size of the file you are importing?
  • Have you tried any other file types?
  • Can you post your crash logs here? They can be found at \Unreal Projects\PROJECTNAME\saved\logs\
  • Can you post your crash callstack and dxdiag here?

Hi StealThyPie,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

I have the same problem here, here is the png that I use from blender (png 16 bits Black and White 1024x1024

It does happen in a FPS Project, the default map with some stuff doesn’t crash most of the time and if I create a new map (with sky) it will crash almost everytime.

Hi ,

I attempted to reproduce this on my end, but have not been able to do so thus far. Do you have any specific steps you are taking to import the heightmap?

The step I use :

  • Launch editor
  • Go in landscape tab and select import with the png
  • Import Progress bar fill normally and as the progress bar disappear it crash sometimes

If I create a new level it will crash a lot more often, If I successfully import one png I will not have the trouble again (it seems)

I can provide a demonstration on skype if needed

Config :
UE 4.12.3
Windows 10 64 pro
I7 920
GTX 760 2giga
Gaming Mouse
Gaming Keyboard

Can you post your crash logs and the callstack that appears after a crash occurs? The crash logs can be found at \Unreal Projects\PROJECTNAME\saved\logs\

Here is the log, I’m afraid the crash doesn’t appear inside. I got no report option from Unreal Engine as I normally do on this particular crash. Here is also a screenshot

[link text][2]

Try running a verify on your engine. If you go to the launcher>library>engine dropdown context menu>verify it should check to see if you have any missing/damaged files and repair/replace them as needed.

I did it, it reinstall the ue4 redist, I did the test again and it crash at the first try.

Here is the call stack as attach (from visual)
link text

edit: Also I will install debug symbol to have a closer look for you

Here is the callstack with the correct name (debug symbol installed)
link text

I’m having this problem as well. I can follow this example:
step by step and crash after hitting Import

Hi everyone,

I was able to reproduce this on my end and have entered a bug report, UE-32551, to be assessed by the development staff.

Do we have any feedback on this issue as I am seeing it with 4.12.5?


Hi fallingbrickwork,

When looking for updates on bug reports, it is best to check out our public bug tracker here. On this, it looks like the error has been fixed and should be implemented in 4.13.

Error still present on my side with 4.13.1 on MacOS. Log attached.

Hi Hamitho,

Can you post the crash callstack here? Additionally, do you have any repro steps for me to recreate this on my end?

Hi ,
I just noticed that it is not neccesarily connected to terrain image import but on landscape creation at all. I tried to create a simple landscape and experienced the same crash. I attached the callstack to this post, I hope it is the right file.

Steps to reproduce are quite simple (at least on my end):

  • Open a (new) project
  • go to landscape tab
  • hit create
  • → progress bar appears for some seconds (0%), then it crashes


What are the specs on your Mac? To get these, please go to the Apple Icon>About this Mac>More Info.

I do not have the hands on my Macbook right now, but you’ll find the detailed specs on the apple page MacBook Pro 13-inch - Tech Specs - Apple
(It’s the 15" with 2.5GHz CPU on the right)

  • 2.5GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.7GHz) with 6MB shared L3 cache
  • 16GB of 1600MHz DDR3L onboard memory
  • Intel Iris Pro Graphics + AMD Radeon R9 M370X with 2GB of GDDR5 memory and automatic graphics switching
  • OS X 10.11 El Capitan