Crash on Game quit

Just upgraded to 4.13.2. Almost every time that I press quit in my game (run console command “quit”) - the editor becomes unresponsive. Same thing happens if I close the game window, instead of pressing the quit button. Not a whole lot of code and no compile/build errors.

Windows 10 - 64 Update KB3199209

Update - Attached logs [HERE][1]

Hi PxRx0xDxIxGxY,

Correct this error (from your logs) and try again.

Error: Unable to load GameInstance Class ‘/Game/Blueprints/Helpers/GameInstance.GameInstance_C’. Falling back to generic UGameInstance.

Also, to cancel out the Editor as a factor, does this occur with a blank Third Person project?

Let us know if this corrects the issue and/or if you still experience this even in a blank Third Person project.



Thanks !
To resolve the issue from the logs I created a GameInstance blueprint with name of “GameInstance”.
I was able to launch a standalone and close without issues.

However, when I deleted the object again the crashes occurred again.
How can I remove the dependency on this unused blueprint?

Also, yes I am able to launch an starter project without issues, but anything I had opened in 4.13.1 first, seems to be having this issue.

Try deleting the object and then right clicking on Contents in the Content Browser and selecting “fix up redirectors in folder.” If this does not resolve the issue, you will have to select this and determine where it is being used/called in your blueprints or code. Running a map check on all levels may help.

How did I not know about that function… that kind of worked. Its now sporadic though.

About every 2 or 3 times after closing the launched standalone game, it freezes the editor. I have no issues launching in the viewport. Logs no longer show any errors, no load errors, map checks are all clear too.

Flow of issue:
1.) Launch as standalone game
2.) Press close button in menu (which runs “quit” command)
3.) Once that window closes, click on editor window - editor is unresponsive.

Here are both logs after a crash:
log1 and log2

Do you have an Oculus Rift plugged in? If so, shut down the editor, unplug the Oculus, restart the editor/your project and let me know if this still occurs with Oculus unplugged.

Hi PxRx0xDxIxGxY,

Since we have not heard back from you in a while, we are marking this post “resolved” for tracking purposes. However, if you are still experiencing issues with the editor freezing up, please respond with the requested information and we will continue to investigate.



Shoot, sorry. Didn’t see that anyone posted since my last reply. No I do not have the Oculus Rift plugged in.

I can confirm this only happens when selecting the option to run as a standalone game. Have been working for the past couple of days with no crashes using the “new editor window”. Attempted standalone game just now and immediately crashed on play. (Game starts up and is playable, but editor unresponsive)

Does this occur with a Blank Third person Blueprint (or any blank template) project or just your own custom project?

I had two projects that I had started in 4.13.1. A personal project, and a vegetation demo project. Both of these crash on standalone game launch.
A blank project (of any type) started in 4.13.2 does not crash.

Vegetation demo project:

The Foliage Starter Kit Demo was created for UE4.7. I’ll will test this to recreate the issue but I need to know which version of the engine you opened it in first? Did you open it directly in UE4.13 or did you open it in a previous version, then open that copy in in UE4.13?

It opened fine for me on 4.13.1. I initially opened it on 4.13.1, played around with some foliage and stuff and saved. Then updated engine to 4.13.2 (no longer have access to 4.13.1) and then opened the project again (now in 4.13.2).

I tested the foliage demo on our Windows 10 system and could not reproduce the crash. However, we have had some non-crash issues with the Windows 10 update that have been addressed in the upcoming 4.14 Release, some of which have been implemented in the 14.4 Preview 3 available now. Please try this update and let me know if the crash persists.

I updated to 4.14 preview 3, and it still crashes when I launch standalone game, nothing new in the logs.

At this point, I am planing on creating a blank project in 4.14 (when it officially launches) and then copying over stuff into the new project, so I will be able to test using the standalone game option.

First of all, thanks for staying around for so long .

I’m not patient enough to wait for 4.14 so I just created a new project in 4.13.2, checked to make sure it would play in standalone (it did), then copied everything over to the new project (maps, blueprints, assets, etc). Checked again, and it did not work (as expected).

I created another new project and am in the process of slowly copying everything over one at a time and checking between each move. I will post an update when I am finished, or get stuck.

Thanks again!

Ok, got all the steps from new project to crashing:

Resources: Ocean Plugin - GitHub - UE4-OceanProject/OceanProject: Environment Plugin Project (Ocean Simulation, Sky Simulation, Buoyancy, Time, Fish plugins for Unreal Engine 4)


1.) Download and unzip Ocean project
2.) Create new blank UE project in 4.13.2 with starter content
3.) Delete all objects from opened level (should be minimal_default level)
4.) Save map as new in Content/levels/MainMenu (not sure if critical for replicating crashes)
5.) Enable “Support global clip plane for Planar Reflections” in Project Settings > Rendering
6.) Copy plugins folder from unzipped ocean project root, to new project’s root as per first step in ocean plugin’s documentation here - How to add to your project · UE4-OceanProject/OceanProject Wiki · GitHub
7.) Copy “Sky”, “Ocean”, and “ShipsAndExamples” folders into new project’s content directory from Ocean project as per second step.
8.) Drag “BP_Ocean” and “BP_Sky” blueprints from “Ocean” and “Sky” folders respectively in the content browser into the world viewport to create new instances of the ocean and skybox.
9.) Run as standalone until crash occurs - ran 3 times before crash occurred.

Attached is an image of the editor after launching and then closing the standalone game. The editor is currently unresponsive and has to be force closed via Task Manager.

Ok, the issue was the Ocean plugin is not compatible with 4.13 yet, and crashing in standalone game mode is standard behavior for this plugin in an incompatible engine version. I found a similar post in the ocean plugin for version 4.8:

I might be crazy, but I was pretty sure it worked fine in 4.13.1, since I started the project it that version and didn’t have any issues.

Solution: use compatible version of engine - latest compatible version is 4.12.

Thanks again for the all the support on this !

Thanks for posting your solution, I’m glad you got it worked out.

Question, is there a way to revert to 4.13.1 to test if it worked in that version and then stay there until the plugin gets updated?