Crash on Editor startup - Runnable thread FAssetDataGatherer crashed

For a while now I’ve been deleting the contents of the folder DerivedDataCache to (temporarily) save space as I understand it re-generates itself from uasset files anyway.

On this occasion however I’m no longer able to open my project at all! I’ve affixed the logs below.

Really appreciate any help! Although I have version control on my code+blueprints I have not archived my entire project folder in a while so I’m basically stuck at this point :frowning:

Note that I have tried regenerating the DDC manually using the “Building Derived Data” fill command described on this page, that didn’t fix the crash (although it does seem to have regenerated stuff)

[2014.12.07-20.57.23:580][  0]LogThreadingWindows:Error: Runnable thread FAssetDataGatherer crashed.
[2014.12.07-20.57.23:580][  0]LogWindows: === Critical error: ===
Assertion failed: InPos<=Bytes.Num() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Runtime\Core\Public\Serialization\Archive.h] [Line: 171] 

KERNELBASE.dll!UnknownFunction (0x000007fefdb6940d) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x000007fee06371c4) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x000007fee04c98c8) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x000007fee04ae892) + 0 bytes [UnknownFile:0]
UE4Editor-AssetRegistry.dll!UnknownFunction (0x000007fed2cc03ee) + 0 bytes [UnknownFile:0]
UE4Editor-AssetRegistry.dll!UnknownFunction (0x000007fed2cc0ea5) + 0 bytes [UnknownFile:0]
UE4Editor-AssetRegistry.dll!UnknownFunction (0x000007fed2cb35bc) + 0 bytes [UnknownFile:0]
UE4Editor-AssetRegistry.dll!UnknownFunction (0x000007fed2cbdcac) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x000007fee0636326) + 0 bytes [UnknownFile:0]
UE4Editor-Core.dll!UnknownFunction (0x000007fee062ad4d) + 0 bytes [UnknownFile:0]
kernel32.dll!UnknownFunction (0x00000000778759ed) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x0000000077aac541) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x0000000077aac541) + 0 bytes [UnknownFile:0]

Crash in runnable thread FAssetDataGatherer

[2014.12.07-20.57.23:601][  0]LogInit: FAudioDevice initialized.
[2014.12.07-20.57.23:625][  0]LogAIModule: Creating AISystem for world NewWorld
[2014.12.07-20.57.23:660][  0]LogDerivedDataCache: Saved boot cache 0.02s 40MB C:/Users/admin/AppData/Local/UnrealEngine/4.5/DerivedDataCache/Boot.ddc.
[2014.12.07-20.57.23:665][  0]LogInit: Texture streaming: Enabled
[2014.12.07-20.57.23:722][  0]LogExit: Executing StaticShutdownAfterError
[2014.12.07-20.57.23:722][  0]LogWindows:Error: Error reentered: Runnable thread FAssetDataGatherer crashed.
[2014.12.07-20.57.23:722][  0]LogWindows:Error: HandleError re-entered.
[2014.12.07-20.57.23:722][  0]LogWindows: FPlatformMisc::RequestExit(1)
[2014.12.07-20.57.23:722][  0]Log file closed, 12/08/14 02:27:23

PS: I realize this is less of a bug report and more of a mess I’ve created on my own but I couldn’t think of a better section for the issue, appreciate your assistance!

Fortunately I found a workaround, hope this helps others:

  1. Open your project in a different version of the engine, select the convert a copy option. Your project should open up fine now. Eg: If you are working on 4.5.1 open a copy in 4.6 and it should work.

  2. Assuming you want to continue working in the original version (which I did), first take a backup of the project that was not working (in my case 4.5.1). Then open that version of the engine from the Unreal Launcher but point it to the new (fixed) version and open a copy (in other words, downgrade the fixed copy back to 4.5.1 from 4.6)

  3. The project should open now but complains that the maps were made in a different version. To fix this you can replace the content folder with the original project that was previously not working. Everything should work at this point.

I think I’m going to stay away from misadventures with DDC files henceforth! I’ll probably make a symbolic link from my SSD to HDD for DDC folders alone. I’m not sure how often read/write operations are done on DDC files so it is unclear how much this will slow the editor down for me.

Hey VSZ,

Thank you for writing up such a comprehensive bug report (and crash report!) for your issue. This will help any other users that run into a similar problem. That said, we’re working on reducing the size of the editor so you won’t feel the need to delete DDCs in the future.



Just started running into this issue on 4.6.1, unable to launch my project and also unable to launch ShooterGame.

Does migrating your project to a different version of the engine and then back to your current version help?

I ran a rebuild of the DerivedDataCache and it seemed to fix it. It affected my project and ShooterGame so I’m not sure changing my project would’ve fixed it.

For anyone else having this issue, make sure to check that you haven’t added any asset packs that aren’t from the correct engine version. That’s what it was for me.