Crash on close or compile BP 4.20

I’ve been beating my head on this for almost a week and have tried everything I can possibly think of to understand and fix this issue to no avail.

Spontaneously over the last week (I haven’t coded much of anything in that time and certainly nothing in the player character, so either this bug existed and I didn’t notice it before or it just appeared for no reason) I have encountered an engine-crashing bug that occurs when I close or hit compile on my player character BP. However, if I save it, then let the engine crash, when I reopen the BP it will have compiled and work normally. If the character is dragged into a world it has the same affect; crash the engine, when it reloads if it saved it works as normal. Playing in editor also works fine. All the game’s systems work entirely as designed when playing with no errors generated.

The player character BP is extended from a cpp class named PlayerCharacter that holds all the logic. Literally the ONLY thing in the bp is a temporary pause menu placeholder function, and a function in the construction script to attach all of his body parts to his main mesh (because it didn’t work in the c++ constructor).
The log file is entirely unhelpful, only having:
[2018.10.27-05.46.22:306][968]LogPlayLevel: Display: Destroying online subsystem :Context_9
[2018.10.27-05.46.28:940][488]LogSlate: Window ‘BP_PlayerCharacter’ being destroyed
[2018.10.27-05.46.28:946][488]LogSlate: Window ‘BP_PlayerCharacter’ being destroyed

It cannot be replicated in a blank project as they do not contain the player character class file (though if it is moved to a blank project it can be replicated). When I make a default character, it does not crash. If I reparent that to the PlayerCharacter’s parent class (the default childed character class that comes with a project), it does not crash. But as soon as I reparent it to PlayerCharacter, it will crash when I hit compile or close the window.

I tried installing the debug symbols to see if they might help, but instead they converted a crash with a log to a silent, error-less crash in which no information whatsoever was given. Is this just a bug with 4.20.3 (As I don’t recall it happening prior to this)?

If anyone can help me figure out what is wrong I would be forever grateful.