Crash Importing Alembic with Multiple Frames

I tried to import alembic files from Houdini using the geometry cache option. I successfully imported the alembic file with single one frame, but it resulted in crashes when I imported the alembic file by a specific number of frames [001-120].

Here are my alembic files:

Single One Frame:

Frame [001-120]:

Hey hanwei,

Thanks for reporting this. I only got a crash because I ran out of memory. The editor jumped up to 45GB memory usage. I’m not sure exactly what’s happening, but I’ve entered UE-43737. You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

Hey ,

Currently this is still unresolved. It was noted that this might be expected with larger files, but 45GB is still a bit ridiculous. It’s been moved to another ticket UEAP-177 which includes a few other general improvements on Alembic Imports. Sorry that’s not very informative, but it’s on the to-do list.

UEAP tickets are not visible publicly. Only UE bugs are visible (UE feature requests are no longer visible).

Hello Williams,

are there any news on this bug? Could you share some outlook for the future of the experimental alembic importer, will it get more love?

Best Regards

Hi ,

thanks for keeping us informed. I cant open that ticket, should i be able to see it?

45GB isnt all that ridiculous for an alembic, they often get to be quite large. Also experiencing crashes over a certain size threshold which is disappointing, although I’m yet to test if theres any compression that can be done to keep UE memory from imploding