Crash every second program start

I’m getting these strange crashes every second start. I run the program once, terminate, then start again and I get this here:

Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) [File:D:\Build++UE4+Release-4.13+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp] [Line: 102]
Detaching from existing linker for …/…/…/…/…/…/UnrealProjects/Client/Content/UMGMiniMap/MiniMap/MovePanel.uasset while object Image /Game/UMGMiniMap/MiniMap/MovePanel.MovePanel_C:WidgetTree_2122.Image_14 needs loaded

Sometimes however this does not happen at all, I can’t make out any pattern. the MovePanel is an UMG widget and the Image, I dont know. Perhaps the render target texture that the minimap renders.

Any idea why an opject can cause this error at program start when there should be nothing in memory?


I was not able to figure out the exact reason. However I did some extensive changes to the MiniMap widget which I bought from the marketplace and it is clear that my changes caused this behavior. Just what exactly it was, I don’t know.

The way I solved this was by reverting to the original MiniMap system and then re-implementing my changes step by step and while keeping the changes to a minimum this time.

Now everything works.

Whatever this error means and how it can be triggered however is something I still don’t understand