[Crash] Editor crashes everytime I exit from Play in editor


I am having an issue where the editor crashes everytime I exit my play in editor session. I have attached the logs, crash dump and dxdiag information to this post. I wasn’t experiencing this before 4.2

Version: 4.2 Launcher

Project uses no code, only blueprints
link text

Here is the call stack

Unknown exception - code 00000001 (first/second chance not available)


KERNELBASE + 43645 bytes
UE4Editor_Core + 2998748 bytes
UE4Editor_Core + 1620298 bytes
UE4Editor_MessageLog + 220355 bytes
UE4Editor_MessageLog + 220607 bytes
UE4Editor_Core + 1549893 bytes
UE4Editor_UnrealEd + 3394853 bytes
UE4Editor_UnrealEd + 1460227 bytes
UE4Editor_UnrealEd + 5375494 bytes
UE4Editor!FEngineLoop::Tick() + 3555 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launchengineloop.cpp:2091]
UE4Editor!GuardedMain() + 476 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launch.cpp:132]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:207]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Ok, I am having another issue now with the same project where none of my assets are getting saved.I just get a message saying failed to save asset with the asset path in the log which isn’t very helpful. This includes maps, materials, blueprints and everything the project contains.

Edit: This just got worse, I am now unable to open other maps or create new maps, it just results in a crash.

I just migrated my content into a blank empty project and I am still experiencing the crash. I also tried migrating the project to a fully updated windows 7 installation and also tried the blank project thing and still no luck. I also tried reverting my blueprints to an older version and still have the same issue. I will continue to investigate other solutions. It would be good to know if others are experiencing similar issues with 4.2

Yes. I had this problem too (crash editor on exit PIE). Then my BPs wouldn’t open. And nobody replied me as yet. I think the solution is just redoom.

Good to know , I don’t think that is a good solution as I would be losing a month of work, this needs to be fixed on epic’s end. It’s good that these issues are being discovered though. Once fixed, the engine will be more stable and friendly towards development. Right now the new releases although impressive are more of a pain than a benefit to some of us. For example in our case it means stopping work and losing money. Working with the folks at epic to get these resolved would be a benefit to the entire community.

Link to 's issue : Unable to update Blueprint project from 4.0.2 to 4.1 or 4.2 - Blueprint - Epic Developer Community Forums

Hi ,

Have you tried reproducing this crash in a blank project with no additional content? Thank you!

Do you guys have an update? Would you like me to provide you with my project? This is halting work unfortunately as it makes iterating next to impossible and is bringing any development except on the art side to a halt…

Hi ,

Could you try re-compiling the ShaderCompiler and see if that fixes it? the ShaderCompiler is located in this file path. \Unreal Engine\4.2\Engine\Source\Runtime\Engine\Public. If you could, please try to rebuild the ShaderCompilerWorker as well.

Hi ,

How do I go about doing that? I don’t really come from much of a programming background. Could you list the steps or point me to the right source?


Hi ,

After you open the ShaderCompiler.sln file in visual studios, follow the directions listed in this link:

Hi ,
I do not see a .sln file in that folder. I only see ShaderCompiler.h. I am using the launcher version of the engine.

the .h is what I meant, I apologize for misspeaking.

no worries. I tried to build it but there is no build option if i open up the ShaderCompiler.h file… I looked around for quite sometime and wasn’t able to find it. The solution explorer says “0 Projects” and there is no build option present if I were to right click on it. Also I am unable to select the solution configuration and build configuration

Yikes, Okay, I just started getting this error this morning. First off, Hypnotic, I think you need the unreal engine source code to build the ShaderCompiler. And , I hadn’t touched any shaders at all when this started.
What i did have was multiple instances of UE4 loading the same uproject. perhaps a bad idea.

I found the issue. In Process Explorer i had some UE4 processes that were still around, not sure how, i’m guessing when i was trying to get localhost multiplayer with server and client instances working, it must have crashed and they didnt exit properly. Anyways, after killing those processes and restarting the editor, everything worked fine.

I don’t have multiple processes running unfortunately and I am still getting those issues. Glad you got it working though!

Edit: I do not have any networking/multiplayer stuff running in my game either

Recompiling the shader compiler and shader compiler worker did not work, I am still experiencing the same crash

Dang that sucks man. Is it limited to just your project? do other projects have the same issue?

Yes it is limited to just 1 project. It started occurring after the first editor restart after upgrading from 4.1.1 to 4.2. All my other projects are fine but they don’t really have much going on in them. I tried upgrading some of the example content to 4.2 and they seem to be fine as well.