[Crash] Dedicated Server with UMG

Hi everybody

Each time i try to run my game with dedicated server, the game crash, i tried with different project but each time it crash, the commonbetween my project is i try to run a menu created with UMG

here’s my crash report , if someone knew how to fix it, it will really help, cos i’m facing this problem since days now


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: PIEInstanceID != -1 [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Engine\Private\World.cpp] [Line: 2043]

KERNELBASE + 37901 bytes
UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 292 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
UE4Editor_Core!FDebug::AssertFailed() + 1079 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
UE4Editor_Engine!UWorld::ConvertToPIEPackageName() + 271 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\world.cpp:2044]
UE4Editor_UnrealEd!UEditorEngine::CreatePIEWorldByDuplication() + 198 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\playlevel.cpp:3257]
UE4Editor_Engine!UEngine::LoadMap() + 5991 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\unrealengine.cpp:8903]
UE4Editor_Engine!UEngine::Browse() + 2024 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\unrealengine.cpp:8115]
UE4Editor_Engine!UEngine::TickWorldTravel() + 813 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\unrealengine.cpp:8311]
UE4Editor_UnrealEd!UEditorEngine::Tick() + 3829 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\editor.cpp:1267]
UE4Editor_UnrealEd!UUnrealEdEngine::Tick() + 22 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealedengine.cpp:347]
UE4Editor!FEngineLoop::Tick() + 4179 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:2257]
UE4Editor!GuardedMain() + 1404 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:142]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hi Zakkar,

Does this occur on a clean project with no additional content? Additionally, can you post the logs from your project here? You can find these at the filepath \Unreal Projects\PROJECTNAME\saved\logs.


Yes it’s occurs on a clean project with no additional content, i found a lot of logs but i only uploaded the last from 2 different project or would you like all the folder ?, maybe you can reproduce it with creating a join/host system blueprint with UMG, and lunch it with dedicated server, the crash happened on 3 different project with the same procedure, i create a lobby system everything work fine without dedicated server, but once i enable it, the crash happen, i hope you’ll find out what’s the matter

Thank you
link text

I think that i found out the problem, but i don`t know how to fix it, the fact is i create a newInstance, and use it to lunch the game, and that what made the game crash

No this is not about my gameinstance, its about the UMG, i created a new project, add a new scene, add a umg with a button, add on blueprint CreateWidget and addToViewPort with the name of my umg, lunch the game on dedicated server whithout single process and the crash happen, before it crash on the console window heres the message
Can`t find the /script/umgEditor while loading

Hello Zakkar,

Could you provide a detailed set of steps to reproduce this issue on our end?

Hi, I have exactly the same problem.
I have just finalized my hud widget (display health), then in the level blueprint I use the “create widget” node to create my interface and display it with the “add to viewport” node. In the editor all works fine. But when I test it with a dedicated server, I have some error in the server log (can’t find the Script/UMGEditor …) and then the server just crash.

I have made a new test with the First Person Template. Same issues occurs. Addind a widget in the project, create it with the “create widget” node and the crash arrive on a dedicated server.

Any solution ?

I just did on the top comment
i created a new project, add a new scene, add a umg with a button to my scene with CreateWidget and addToViewPort on blueprint, lunch the game on dedicated server whithout single process and the crash happen, before it crash on the console window heres the message Cant find the /script/umgEditor while loading

Hello Milen ,

I was unable to reproduce this issue on our end.

Steps taken:

  1. Created widget
  2. Added it to the viewport
  3. PIE with Dedicated server
  4. No Crash

This is the information I have gathered so far from what I have read on this post. Could you supply me with any missing steps to reproduce this issue on our end?

I dont test de dedicated server inside the editor (PIE) but with a shortcut on my desktop configured like this :

Target : “” “” FirstPersonExampleMap?game=Test -server -log

Start in : “”

The “Test” parameter used in the “Target” of the shortcut is an alias created in the DefaultGame.ini:


I use that to have a eye on the log of the server in real time (connection of players, real time computing, etc).

Hope that will help you to recreate the issue.

Hello Zakkar,

I was able to reproduce this issue on our end. I have written up a report ( UE-11311) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Thanks for looking into this, I hope this gets fixed soon (4.7.3?) since it’s a game-breaking issue.

A workaround has been submitted to the master branch. If you are running from source you can give it a try.

Is this fixed yet or do I need to turn off the hud until this gets fixed on their end?

Hello ,

I went ahead and double checked on this issue for you. I have found that this has been resolved internally and that it will be available in a future release of the engine. I hope this answers your question.

Make it a great day

ok sounds good, hopefully we will see a preview build soon as this is really making it hard to test my dedicated server. Having to constantly build the entire game any time I want to test server function is a big pain in the butt.

OMG! This really works! It saves me so much time not to spend 5 minutes every time to pack a dedicated server.

Good . I solved the problem.