Crash after turning on "GenerateMeshDistanceFields"

I recently had to delete a couple of unused assets from my project. For some reason Unreal had to build Mesh Distance Fields every time I touched an asset, so the process became extremely tedious and I turned off GenerateMeshDistanceFields in the project settings. Now that I’m done with the deletion and want to turn the setting back on, my project crashes every time I start it. It starts up normally at first, then starts “Building Mesh Distance Fields (3)”, then starts “Baking Landscape Textures (115)” for some reason, then crashes immediately. Setting “r.GenerateMeshDistanceFields” to false again in the DefaultEngine.ini prevents the crashes.

Crash report:

Access violation - code c0000005 (first/second chance not available)


UE4Editor_Renderer!FDeferredShadingSceneRenderer::RenderLights() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\lightrendering.cpp:526]
UE4Editor_Renderer!FDeferredShadingSceneRenderer::Render() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\deferredshadingrenderer.cpp:1145]
UE4Editor_Renderer!RenderViewFamily_RenderThread() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\renderer\private\scenerendering.cpp:1582]
UE4Editor_Renderer!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`20'::EURCMacro_FDrawSceneCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\async\taskgraphinterfaces.h:779]
UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\async\taskgraph.cpp:539]
UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\async\taskgraph.cpp:340]
UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\rendercore\private\renderingthread.cpp:310]
UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\rendercore\private\renderingthread.cpp:411]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Hi Efrye,

I’ve tried to get this to happen based on your notes, but I’m not getting a crash on my end.

Can you do me a favor and post your Logs from Your Project Folder > Saved > Logs. Just zip this folder up and attach to this post.

Also, are you able to reproduce the crash, if so, I’ll need to know what your Machine and Epic ID are to locate the call stack in our crash reporter system, assuming you’ve submitted these and not just closed the crash reporter window.
If you have submitted, but are unsure what your machine and epic id are you can use the console command debug crash to cause a crash and these IDs will be located in the crash reporter window.

Aside from that, are you are able to reproduce this in a new project at all, or is this just something that you can reproduce in your project?

Thank you!


Hi Tim,

Thanks for your reply!

Sorry, I forgot to mention that this is a specific problem with my project. I wasn’t able to reproduce this with any other project.

I just tried making a copy of my level, removing the landscape, setting it as default map and then turning GenerateMeshDistanceFields back on. This copied version of my level with no landscape works just fine, but as soon as I open the original version, the editor crashes immediately.



Logs Download

Looking at the source context for the crash in our crash reporter the call stack seems to look like something with LPV (Light Propagation Volumes) enabled possibly. Do you know if this has been enabled in your project by adding the line r.LightPropagationVolume 1 to your Engine Config Console Variables ini file?

If so, can you disable/remove that from the consolevariables.ini file and see if the crash still occurs. I’ll try and reproduce with that enabled as well to see if I can get anything to happen.

I’m indeed using LPVs for my project, but unfortunately it still crashes even if I disable it in the consolevariables.ini.

It also crashes immediately when I try to create a landscape in the copied version of my level that I mentioned in my last post. It does not crash, however, when I create landscape in a new level in the same project…

Turns out the crash is caused by the “r.GenerateLandscapeGIData” setting, regardless of whether or not LPV is turned on. Turning this setting off lets me load up my map without any issues. I suppose this feature is supposed to improve the performance of real-time global illumination in combination with landscapes?

Unfortunately, I’m not seeing the same results on my end with the crash. Also looking at your most recent crashes with this in our Crash Reporter system it’s still showing the same call stack. So, I’m not completely sure then.

Using the r.GenerateLandscapeGIData with 0 will disable landscapes color bounce, but still allow a single bounce of light from any static meshes that are near or in contact with it.

I see, I guess I’ll have to live with it for the moment. Maybe I can figure out the exact cause with some more experimentation, or, if I’m lucky, a future update will fix the problem for me.

Thanks again for your help so far. I’ll comment again if I make any new discoveries.

Thank you.

I use Distance Fields often, even GI even with it being experimental, If I happen to get anywhere with it I’ll do what I can to repro and post back here for you as well. Thanks for all your help and patience.