Crash after launch with below min spec GPU

This error seems related to the ATI Radeon 4650 chip I’m using.

I’m getting an error thrown here.

D3D11VertexBuffer.cpp Line 69.

It tries to create the vertex buffer and throws an error.

Interestingly, if I find where D3D11_ALLOW_STATE_CACHE is defined as 1 and define it as 0, everything seems to work.

Two questions.

  1. Am I missing anything besides a speed hit while rendering by that #define?
  2. How do I compile the editor in release mode? I see the option for Development Editor but not for Shipping Editor.

Thanks,
Ralph

Sorry, to be clear, the shipped editor crashes, when I downloaded the source and run it, I get the actual error and line it happens on.

Hi Ralph,

Thank you for your report. Could you please post your crash callstack and log file? Your log file is located in your [Project Name]/Saved/Logs folder.

Thank you,

Alexander

Here you go. This is from the current Git version built with VS2013. I’ve got an ATI 4650 video card, which is most likely the culprit.

UE4 Built from source Crash

It does look like my video card is below the minimum requirement, although I plan to do most of my work in C++ so if setting that macro will continue to work, I’ll be happy enough…

Removed Zip file and put into answer below.

Here’s the DLL that needs to be replaced. It turns off vertex caching, so I can’t guarantee it won’t cause other issues, but it will slow things down. Actually, I won’t guarantee anything, including it not causing a nuclear explosion, so use it at your won risk.

It only effects the editor,so you can’t run anything outside the editor until/if someone fixes it.

It needs to be unzipped and put here, back up the existing file of the same name first.
C:\Program Files\Unreal Engine\4.0\Engine\Binaries\Win64

Removed Zip file and put into answer below.

Hi Ralph,

Thank you for your patience. I have reported this issue to our rendering specialists and we are working on a resolution.

The problem is that my video card is below the minimum. Not that anything built with the current build will also not run on my machine, so I hope that gets fixed.

The DLL that needs to be replaced is posted here. based on the change that Nick has a pull request for.

https://github.com/EpicGames/UnrealEngine/pull/8

I won’t guarantee that it will work for you. Actually, I won’t guarantee anything, including it not causing a nuclear explosion, so use it at your won risk.

It only effects the editor,so you can’t run anything outside the editor until/if someone fixes it right.

It needs to be unzipped and put here, back up the existing file of the same name first. C:\Program Files\Unreal Engine\4.0\Engine\Binaries\Win64

link text

No worries, I’ve worked around it. My much bigger concern is that I can’t run the very simple Unreal 4 game I built. It has the exact same problem.

Thanks a lot, the engine starts up just fine now! :slight_smile:

Hi Ralph, thanks for all of the information and work around! I am going to try looking in to the crash on our end, but as we can’t reproduce the crash here I’d appreciate your help if you don’t mind :slight_smile:

Can you:

  1. Disable your workaround temporarily.
  2. Run the editor with -d3ddebug on the command line
  3. Attach the log file when it crashes?

Thanks!

Thank you for letting us know about the second issue. We will be looking for it now as we work on a fix.

Actually, I think I have found the problem. I’ll test a fix here and try to get a patch up on GitHub for you to verify!

Thanks Nick!

I’ve checked in what I believe is a fix to our main p4 depot here at Epic. I’ve also committed a change to my repo on github:
https://github.com/nick-penwarden/UnrealEngine/commit/4917533f7c2b23464a8ae4c19d4db67ac7df768b

And added a pull request:
https://github.com/EpicGames/UnrealEngine/pull/8

I’m a total newbie when it comes to github, so I’m not sure which is more convenient for you. Also I’m not sure why the diff is broken, but it’s a rather small change.

Let me know if this works for you!

I see the change.

Diff is probably broken because of different line endings. There’s an option to either leave them alone or switch to linux (or maybe windows) which checking in. I’m not sure what the standard is, but that’s my best guess. I’ll let you know if it works.

I pulled the change and verified that it works on my machine :wink:

Thanks Nick!

Hi,

I am having the same issue with graphics card requirement and dx11 vertex buffer error.

I will try your fix asap.

Thx very much for sharing.

Haha this is too good to be true :

Renamed & Replaced the original file with nick_penwarden’s commit.

Compiled with “Development Editor” configuration.

Now Editor is working on my wooden mobilty radeon laptop !!

ATI Mobility Radeon HD 4500/5100 Series

Good job guys, epic support.

Great news, glad this fixed your issue as well!