Download

Crash after installing Visual Studio 2019

On a new pc. I am working on my project without too many problems. Tried to package it to test if it would play and was told I needed to install Visual Studio 2019 to do that, so I did. Now no project will start, they all crash on startup with the error code

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x000000002ebe1e90

I am using 4.26.2.

Crashes on launching just the engine too.

here is what I installed on VS 2019

Wondering if I installed the right stuff or if there is something else I need to do?

Edit—

Tried the verify on the engine and that did not work. Uninstalled VS and still getting the error. Now I still cant open engine or any projects and I don’t have VS Installed.

-UPDATE -

Seems it might be a hardware issue, other games and programs are not working. I will update again if I find a fix.

0x000000002ebe1e90 is not an error code, it’s the exact byte in memory that the program tried to write at – which failed.


To get a more clear error message, you could install the debugging symbols for the editor.

This illustration explains how (credit @GeneralSoundwave)

I’ll get the debug tools downloaded for future use in case I need it. The problem seems to be outside ue4. Its something with my hardware, grafix card, Drivers or a Windows update that messed something up. It is not only UE4 that was having problems other programs were messing up and i am seeing graphical errors and glitches in windows. I am getting a new grafix card soon and i will post if that was the problem.

NachoMonkey2, thanks for the info on the error code I have no experience in this and appreciate the knowledge.

Is there a way to tell what hardware the memory error was in, GPU, Ram, HD , or somewhere else?

No. However, if you send the error after the debug symbols have been installed, I probably could narrow it down.


Please–don’t interpret what I said as the memory is failing–when I said it failed to write to memory, that’s because the program doesn’t have authority to write to anywhere in memory.

OK just got the error again, not sure what files to send. Or if i have enable the debug tools in some way.

The log file should be located at Unreal Projects/PROJECTNAME/Saved/Logs/PROJECTNAME.log

Only send those logs if you haven’t launched the project again since the crash, otherwise it will be in a different file.

Thanks for the info I will post the files if it happens again. After doing a lot of digging on the net and on my processes I found that if i disable Nahimic.exe service from even starting up Everything works fine except one of my sound programs that is reliant on it. Seems windows installed it during the last update, I don’t know why because everything was working fine before that. Anyway I hope that the problem is solved but if I get the same problem I’ll post the logs. I will give it a few days and if it is Nahimic software that is the problem ill change the title of this post to reflect that. Again thank you for the info and your help.