Crash - 4.15.0preview1 during "Open a copy" of a project on Mac

I tried to open my 4.14.3 project in 4.15.0preview1 on macOS using the “Open a Copy” button.

It crashed very quickly – no crash reporter, just the macOS system crash dialog.

Here is the OS crash log

I tried manually making a copy of the project and then doing “Convert In-Place” while opening it with 4.15.0preview1. This also resulted in a crash, but this time I got the UE4 Crash Reporter:

Crash Logs

Hi CleanCut,

I’m having difficulty tracking your crash in our track reporter database? When the Crash Reporter was present did you hit the send button?

Also, are you able to reproduce this crash or did this just happen once while trying to convert your project in place?

Please respond with this information and we will continue to investigate.

Thanks,

Steve H.

Steve,

Yes, I hit the send button on the crash reporter. (“Send and Close”, specifically).

I tried converting it again. It appeared to get the exact same error. This time I typed in a message, took a screenshot, and pressed “Send and Restart”. Here’s the screenshot:

Immediately after the dialog closed it tried to restart and crashed again with the same error. Very reproducible…for me.

I was able to locate your crash information this morning and have found the bug you are experiencing has a bug report already open: UE-40781. However, in order to pinpoint the cause we need to be able to reproduce this in house.

To that end, would you be willing to provide us with a copy of your project so that I can try to open it and reproduce the results on one of our Macs? If so, please provide a link to your file zipped and uploaded to Dropbox, Google drive, etc. sent to me in a Private Message on our Forums.

I’ll also need your Mac’s specs in order to test on a similar machine and in the correct OS.

1 day ago my issue was closed, but in my case i just run UEditor from launcher (without any project) and then it crashes:

i sent yesterday 6-8 reports from macbook air and iMac as well.
problem still

Hi PirateTony,

Your issue was closed because you are experiencing the same crash we are investigating as UE-40781 on this post.

In order to help identify the issue, please provide your system specs. Also, since this is not crashing on a specific project, please try to open the editor by navigating to UnrealEngine>4.15>Engine>Binaries>Mac>UE4Editor and right click, select “Open” to try and open without the Launcher.

Try after restarting your computer to make sure you are starting “fresh.”

Thanks,

Steve H.

Steve, I can’t find you on the forums. What is your username?

Steve, my system specs are below. I will PM you a link to the project to download through the forum.

Steve Hardister Try this link: https://forums.unrealengine.com/member.php?21610-Steve-Hardister

Ah, the substandard webapps rear their ugly heads again. You don’t come up in a search for “steve” or “hardister”, because the forum search is case-sensitive. :stuck_out_tongue:

Quick update, in case you did not receive my reply to your PM, I was able to download your project. I’ll update here whether or not we could reproduce the issue. Thanks again for your cooperation in helping to identify the source of the bug.

I replicated the same crash on my Mac Pro (different set of hardware)

123090-screen+shot+2017-01-21+at+2.51.08+pm.png

123102-screen+shot+2017-01-21+at+2.51.18+pm.png

123103-screen+shot+2017-01-21+at+2.51.27+pm.png

Hi Cleancut,

Thanks for supplying a sample project -it was a great help in isolating the issue quickly. The bug has been resolved and the fix scheduled for the next engine preview.

-Steve H

@Steve Hardister Glad to hear you were able to isolate the issue and fix it! Don’t you love it when a plan comes together?

Confirmed fixed in 4.15.0preview3