Download

Crafting Items in an external inventory question

I am so confused right now. I thought for an item to auto-craft in an inventory for example Kibble, that it had to have the inventory listed in “Crafting Requires Inventory Component” and it had to be listed in that inventories list under “Default Inventory Items.” I set it up like this for my dehydrated berries and it worked like a charm. But I am working on something new and I was studying the “Health Pot” and “Kibble.” Neither of these are listed in the “Default Inventory Items” for the cooking pot which they can be made in and on top of that neither of them have the cooking pot listed in the “Crafting Requires Inventory Component.” So now I don’t get it. How do these know they are crafted in the cooking pot? What am I missing?

Thanks in advance for the info! :slight_smile:

Sometimes when you make a child of a certain object the blueprint will work in the editor but will not be cooked and made for the live version. Especially if you have the do not cook this item enabled.

Now in respect to what you’re doing, you need to give us more information.

  1. What are you making?
  2. Are you trying to edit core files?
  3. TC mod or normal mod?
  4. If you’re trying to add things into a core structure, have you added it into the additional structure engrams list?

Its not so much what I am making at the moment that worked just fine with the “Crafting Requires Inventory Component” and “Default Inventory Items” combo. But the whole thing was just something I noticed while studying the files. I finally found where kibble is listed. If you go to the components tab and look at the inventory there all of the kibbles are listed and it looks like they renamed the inventory in the components. This mean that inventory is separate from the one listed for the item. Meaning when you change the inventory in the components tab it does not change the blueprint it was linked to if you rename it. At least that’s what it looks like to me. Why they did it this way I have no clue.

When copying a structure to make your own version, you have to duplicate not make a child, go against the OOD approach, as inventory components are protected and not replaceable/editable.

If you want to add things to the fireplace, don’t edit the fireplace, and use the additional structure engrams. As you will have to remap the fireplace if you want to edit it, and not add to it. While remapping is an option given to people by Studio Wildcard it’s a messy workaround that gives stacking conflicts with multiple mods.

I was looking at the additional structure engrams for another mod I am working on but could not get it to work. I wanted to add a new club to the smithy. Tried a bunch of different things but could not get it to show up in the smithy. I created a new additional structure engram had my stuff listed in there but still didn’t work. Do you have any experience doing this? Could you give me a detailed walk through if you do? Please.

nothowyouexpect.jpg

Like that. They really need to change the names, but the problem is, they have no naming convention for the actual blueprint, the core one, the one that links everything and has the components and you attach graphs onto.

You add the Anvil’s [CORE] BP and insert your [PrimalItem] [Structure|Weapon|Item|Resource] into it. And that is all, you don’t edit the item in any way. Just make sure not to “add blueprint to player inventory” otherwise 75% of the ark players will think it’s hand crafted and spam your mod for a few months, instead of just read “Crafted in Smithy”

Thank you so much for the info can’t wait to test it out. you have been a huge help thank you!

i may be late for the party, but does that mean we CAN craft MOD stuff inside the vanilla smithy without any further issues??

Yes? (need to have more then 10 characters so adding this message to the end)

But only if the “new items” are created with resources that are already allowed in the vanilla smithy (so no possibility of new resources). If you need new resources, the inventory of the smithy would have to be altered which would require you to make a new smithy. Correct?

Pretty sure you are correct Swiss. Not sure if there is a way to add new default items to existing structures.

Correct, you can’t do that without remapping the structure to a different version.

And remaps cause stack conflicts.

There used to be 2 problems with this…

  1. New items were not craftable in existing stations already placed, only if you placed a new one.(smithy, cooking pot etc.)
  2. If the server is restarted the new items disappear.

Have these issues been fixed lately? (I have not tried since the latest updates)