CPU temps 80C when opening external project

Hi, I am making a game for a game jam but, I developed the game on an another OS and want to export it, so I have to use Windows, when I copy the files on the same computer to Windows and load the project, it uses 78% of CPU and temps are 80C can I make it use less, I am ok with it being slower.

No replies and views? Why do the other recent threads have so much more views and replies?

Try to reduce the amount of calculations done on tick if you have them. Turn of tick actor and tick component where possible.

Game jams usually have you doing messy code because it is quicker. That will lead to high cpu usage without optimization (usually needs variable caching, object pooling etc)

No, it happens when I open the project, and it compiles shaders

Try switching to 5.1 it compiles shaders on demand. It will only compile what is needed at the moment.

It is updating, but I want to ask a question, Was that necrobumping I just did bad? Should I post at this time instead in the future instead of necrobumping?

Still same temps, when opening

What cpu model?

Ryzen 5600G

Ryzens tend to run hot under load. it’s normal. (my 5950x can get close to 90) You can probably cap the temperature in your bios if it is newer motherboard model.

No, I can’t do that in the BIOS, from what I remember

Easiest way is to use the windows power setting. Knock it down a notch and see if that works for you. I had the exact same problem and that was the best solution for an out of control CPU.

Assuming your cooling solution is okay, then the temperature of the CPU shouldn’t matter – it will work as specified within the specified temperature range. That’s how it’s designed. Be happy that you have many cores that can compile shaders for you.

If your cooling solution is not okay, then the problem really is the cooling solution, not the programs you run on your CPU. The work needs to be done, no matter what …

If you still want to run slower and cooler for some reason, you might be able to turn off SMT, and perhaps turn off frequency boost, in the BIOS, even if you can’t set a different temperature threshold. This will cause the CPU to work less hard, and thus generate less heat. Whether that will cram you in under the temperature limit you want, you’d have to test to find out. Worst case, keep under-clocking.

I said above that moving the power setting down a notch in windows solved my problem. but the post above reminded me that i put in a noctua and made sure i did a thorough job with the paste with the penta dot thermal paste arrangement. That kept my temps under control by far. Until that point i was paranoid about high temps. Now it can go on a CPU usage in the 90 percent for extended periods. Noctua NH-U12A chromax.Black, 120mm Single-Tower CPU Cooler - I like this black version much better than the weird Desert Storm brown. How did this brand survive that era? :slight_smile:

I switch off Realtime. For some reason Realtime heats the crap out of my machine.