Couldn't think of anywhere else to post this

So this started about two weeks ago when Borderlands 3 began crashing on launch for me out of the blue. I ran out of ideas of what to do to fix the issue so I uninstalled Epic Games Launcher and all my games that were linked to Epic were deleted as well. Fast forward to today when I tried playing Remnant and immediately noticed that the game would crash upon start up. The code that Unreal Engine gives me says “Remnant_Win64_Shipping” repeating multiple times until “kernel32” followed by “ntdll” Here are my specs Any help would be appreciated as I was planning on re downloading BL3 when my WiFi data resets for the month however I am going to hold off for now until I get Remnant running. After trying more I noticed another line from the crash reporter saying “Unreal Engine is exiting due to D3D device being lost.”
Any information that can help me solve this issue would be greatly appreciated. I haven’t experienced any issues with any other programs, just games that run on UE.

Is that on laptop or desktop? For laptop you may try cleaning, it can overheat due to accumulated dust.
If that is desktop, your graphics card may be dying or ram.
You should eliminate possible causes and what is left will be culprit.

First check if that is os or hdd fault, for that install clean os on another harddrive and see if same crashes happen.
Then borrow\get new graphics card replace it, and see if it crashes.
Last would be doing this with ram.

I know that all may be hard nowadays, so at least try new os on empty harddrive, any working hdd will do it, you just need to see if that is software or hardware problem (if it still crashes on new os it is hardware, if it does not you neeed to reinstall os or try different drives etc).