Couldn't import obj file

I couldn’t import obj from the attach. UE editor just consumes all memory (I have 16 Gb) and then crashing.
link text

On previous UE version I could import this file, but couldn’t drag and drop those meshes to the scene, with same result - crashing when memory is over.

Hello ershovdz,

This worked fine on my end.

If you would link me the rest of your DxDiag I will continue to see what could be causing this.

From your screenshot I see, that you combine all meshes to one big mesh. I need to set up materials for those meshes. So I don’t combine meshes during import. Please, try to import meshes without combining.

The same issue on another computer with Nvidia Geforce GTX 980 gpu and 16 Gb ram memory. It’s just one floor.

It took a second but everything finally imported.

And now, may you select all meshes together and drag and drop it to the scene ?

So I just tested the drag and drop. The process did not crash the engine. However, it did freeze. What I can surmise is you are trying to handle too many events at the same time. There are nearly 1900 objects that you are trying to bring into the viewport. My recommendation is to import, maybe 400-500, at a time and zero our their orientations within their details panel.

I do not believe UE4 is designed for this. You mentioned that an earlier version you had a similar issue with not being able to bring them into the scene.