Couldn't find Visual Studio Enterprise 2015

Hey guys,

I just git pulled the latest release of the UE4 source code. On this computer I had never installed UE4 before and I only have Visual Studio Enterprise 2015 installed. When I run GenerateProjectFiles.bat, however, it outputs, that the script found no version of Visual Studio installed. I already checked the Registry, and the InstallDir value is set and correct, so there should be no problems, right?

Anyone got an idea why it isn’t working?



If you want build solution for VS 2015 you need use parameter “-2015”.

GenerateProjectFiles.bat -2015


unfortunately the -2015 parameter does not work or print out a different error message.
It was apparently only needed in 5.09.

Thanks for the answer nevertheless :smiley:

Since on Win10 you can copy from cmd, here is the full error message:

GenerateProjectFiles ERROR: We
couldn’t find a valid installation of
Visual Studio. This program requires
Visual Studio 2015 or Visual Studio
2013 or Visual Studio 2012. Please
check that you have Visual Studio
installed, then verify that the
on 32-bit machines) registry value is
set. Visual Studio configures this
value when it is installed, and this
program expects it to be set to the
'\Common7\IDE' sub-folder under a
valid Visual Studio installation

Some time has passed and I tried downloading the source code and reinstalling binaries etc. several times. Still, the error message persists when running generateProjectFiles.bat with or without Admin rights.

I just don’t see a way, could someone please help me?

Right after asking the second time, I started to play around with the PATH environment variable, which contained
C:\Windows\system32 and

Moving the first one below/ behind the other one seems to have fixed the problem.
Now I am getting
UnrealBuildTool Exception: ERROR: Windows SDK v8.1 must be installed in order to build this target.

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.
but this should be fixable by just downloading Win SDK 8.1 manually, which I am doing right now. If this leads to problems, I will ask another question.