Couldn't find file for package /Script/SequencerScripting

Hello guys,

I’m here looking for a solutions for this issue I’m having trying to package my game,

I have this error when I launch my AR project in an Android Device, it launches but when I try to open the app, or simply do an action in-game, the app crashes. When it crashes this error appears in the Output Log:

LogPlayLevel: Error:   08-07 09:41:51.108 21246 21299 D UE4     : [2020.08.07-15.41.51:108][  0]LogStreaming: Error: Couldn't find file for package /Script/SequencerScripting requested by async loading code. NameToLoad: /Script/SequencerScripting**

LogPlayLevel: Error:   08-07 09:41:51.108 21246 21299 D UE4     : [2020.08.07-15.41.51:108][  0]LogStreaming: Error: Found 1 dependent packages...*

LogPlayLevel: Error:   08-07 09:41:51.108 21246 21299 D UE4     : [2020.08.07-15.41.51:108][  0]LogStreaming: Error:   /Game/Blueprints/GameFramework/BP_SequenceData

How I mentioned earlier this is a blueprint only AR project and I’m using some of the features of the Sequencer Scripting plugin provided by the engine. The system runs wells in Editor, but it crashes in Android.

I’m having this error since I moved my project from 4.24 to 4.25.

Things I already tried:

  • Zipped the project (same error)
  • Deleted intermediate and saved folders (same error)
  • Created a C++ class (same error)
  • Created a new blank project of the HandledAR project (surprisingly it launch & package well without problems)
  • I also tried to add the files in the error to Additional Assets Directory to Cook, I tried with these ones: /SequencerScripting, /SequencerScripting/Python, /Script/SequencerScripting, /SequencerScripting/Script/SequencerScripting (Got the same error)

I’m running out of ideas, I will appreciates so much if someone have a solution to this

Thanks in advance!

I have the same Problem but the Game is crashing with “Fatal Error” on Windows build. Same Log Message. And I also use Sequencer Scripting.
Do you solve this issue or is there something new about this? Thanks…

I solved my Issue with this error today. For me the “Set Playback Start” Sequencer-Blueprint-Node causes the error. I removed it and now my build is working. Im relative new to unreal but maybe it helps you or somebody on tjis sequencer errors.

Hello! Thanks for your response,

I ended up solving this one in a different way,

In my project, I was accessing the information of the Marked Frames of some Level Sequences. The error was caused because I was trying to access the information of a Marked Frame in real-time on an Android device (in PC this error didn’t occur).
To solve this error, I stored all the Frames of these Marked Frames in a local blueprint in the scene, to access its information in real-time.

To sum up, if you are using the node “Get Marked Frames” from the Sequencer Scripting plugin it will work fine on PC, but it will crash on Android. If you really need this feature in your project, just grab those level sequences marked frames and store the information in the scene before launching/packaging your project.

I hope this helps someone else struggling with this issue.

i had similar error. for me the fix was enabling ue4’s Sequencer Scripting plugin.