Download

Could you please offer a bit more info about UMG status?

Greetings.

One of the nice things on 4.5 was exactly that you got UMG “out” from the experimental status.

On hear this looked like I could start my HUD implementation (as many other users I think), but after get some progress today I noticed that UMG Buttons were not getting hover events, while the “style” points an image to theoretically do a swap, changing images and so on…

On look by answers, I’ve found this:

https://answers.unrealengine.com/questions/122518/45-umg-how-to-get-onmousebutton-events.html

Where Mr. Tripplet (marked as staff) says that UMG system does not currently support mouse input…

“BUT” I have a project here done on a previous version (I think 4.4) where a Slider still working with mouse.

Of course, the slider effect is bound to a valuechange Event, but I could imagine the “Slider Handle” element still being something as a button that checks mouse button press and some hitbox to allow sliding it.

Sort of confuse here, a bit more info will be really appreciated.

Best Regards.

I’ve updated that thread :slight_smile:

Your buttons may be behind something that is handling the mouse input, preventing the hovers. If you have objects that are hit testable, they can absorb the mouse input.

It’s still very Slate focused, but I would recommend using the Widget Reflector to figure out what is under the cursor. You can access it using the Developer menu under Window, or, you can user my favorite shortcut Ctrl+Shift+W. Then you can ‘pick’ any Slate UI to figure out how it’s composed, what created it, all kinds of useful stuff. The important thing is it will tell you what is eating the mouse before it hits the button.

Cheers,
Nick

Hi Nick thank you by the Widget Reflector tip.

The “OLD” Widget BP works with the slider because the input pass trough the Editor Viewport.
But, when I switch Widgets back to the “NEW” graph, the input stopped on the Editor Viewport.

Should be impossible the own Editor Viewport be stealing my input, so I figured out that was not someone eating my input, was nobody “eating” it inside the Editor Viewport.

After go trough “all” components hittest settings, by accident I clicked on “Root” and noticed that it “also” has hit visibility settings AND I’ve turned it hittest invisible without think that this should kill all my input to the UI (I thought that such settings should just be active from the First Canvas and upper).

The right setting should be “Self Hittest Invisible” and everything works fine now. Thanks, I would not figure this without your reflector tool tip. I’ll keep that shortcut almost “always on” now. :smiley:

I just have one last question (c’mon, I wanna post a video after to show to you and Matt the entire thing working lol).

How I could get Matinee to record gameplay and also displaying UMG?

Thank You!