Could really use some help with Virtual Camera

I’m working to get the Virtual Camera working but have been struggling for a couple days now. I have been trying to get my iPhone to connect via Remote 2 and also tried Live Link VCAM. I am able to connect to unreal but can not get it to connect as a source in Live Link. I was thinking about getting a Vive Tracker to test it with instead but would hate to waste the money and still have it not connect so would love to test it first with what I have.

I have tried every fix I came across. I am on a Mac and have tried to go through all security settings for networks with no luck, both on the phone and computer side. I have followed multiple tutorials step by step and can’t figure out what is stopping it from linking with Live Link. Once again, I can link to unreal and open settings, etc from the remote program but Live Link never sees the input source to utilize for movement tracking. Is there something on Mac that I may need to do differently than all the PC tutorials out there? For example many say that switching their network to private worked however as far as I can tell Mac does not have this option/setting. I tried many other network, security, privacy, and accessibility options.

Any assistance would really be appreciated at this point, I’m starting to rack my head a bit. Thanks in advance!