Could not find file [Project Name]-9891.dll.response

This started to appear whenever I compile my project in editor or in VS under Development Editor:

CompilerResultsLog: New page: Compilation - Aug 14, 2015, 6:35:48 AM
CompilerResultsLog: Info Compiling game modules for hot reload
CompilerResultsLog: Info ERROR: System.IO.FileNotFoundException: Could not find file 'C:\Users\Cody\Documents\Unreal Projects\Editor3\Intermediate\Build\Win64\Editor3\Development\UE4Editor-Editor3-9891.dll.response'.
CompilerResultsLog: Info File name: 'C:\Users\Cody\Documents\Unreal Projects\Editor3\Intermediate\Build\Win64\Editor3\Development\UE4Editor-Editor3-9891.dll.response'
CompilerResultsLog: Info    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
CompilerResultsLog: Info    at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
CompilerResultsLog: Info    at UnrealBuildTool.UnrealBuildTool.PatchActionHistoryForHotReloadAssembling(List`1 OnlyModules)
CompilerResultsLog: Info    at UnrealBuildTool.UnrealBuildTool.RunUBT(String[] Arguments)
LogMainFrame: MainFrame: Module compiling took 0.793 seconds
Warning: HotReload failed, recompile failed

Happened literally between builds.

That folder has three files

  • Editor3.exe.response
  • Makefile.ubt
  • UnrealHeaderTool.manifest

Not sure what I need to do… Tried cleaning and rebuilding the project.

Hello codysmith105,

I have a few questions to ask you to try and diagnose this issue.

  1. Is this something that only happens with your project? Can you try making a new C++ project to see if you receive the same error?
  2. Did this occur at all prior to 4.9? If not, and you still have a copy from an earlier version that you can test to if it occurs there with your latest edits?
  3. I see that the log mentions that HotReload has failed; Do you still receive this issue when building without having the editor open?
  4. Is this issue only preventing HotReload or is it causing the compilation itself to fail as well?

This has only happened on that one project, I’ve since imported by assets into a new project and haven’t seen the issue since. I can send you the problematic project if you wish.

If migrating the assets into a new project fixed the issue, it could’ve possibly been caused by conversion to a new version. If the issue presents itself again we can investigate further but as of now I’ll be marking the issue as resolved.

This has happened again, seems to have something to do with cleaning a project.

Hi codysmith105,

What exactly do you mean when you mention ‘cleaning’ a project? It could be multiple things so I’m curious as to what you mean exactly.

Hello codysmith105,

We haven’t heard from you in a while. Are you still experiencing this issue? If so, please leave a comment and let me know. In the meantime I’ll be marking this as resolved for tracking purposes.

Hi , I also have this problem, it still occored on 4.9.1
And I accidently did clean the visual project just before…

Hi, same here! I have just cleaned my project and ever since I am getting this error. Any solutions to that issue yet? Thanks a lot!

Hello overseb and mikriloulou,

As I asked codysmith105 before I lost contact with him/her, what exactly do you mean by cleaning your project?

I guess they did a righclick->clean in visual studio… like i did.
And i have the same problem now and dont know how to fix it :confused:

I’m not having any luck reproducing this by using the Clean function in Visual Studio. Would it be possible for any of you to attempt to see if this issue occurs with a fresh project as well? Also, would it be possible for anyone to send a copy of a project that is having this issue?

I have just had this same issue. I did a clean in visual studio and it has the exact same error after I right clicked and did a clean and now I can’t compile from inside UE4. I can still compile in VS

Thank you for letting me know that this still occurs, BlueByLiquid. I would like to get a reproduction case on this issue so that we can work on fixing it internally. Would it be possible for you to send me a copy of the affected project? If you wish for it to remain private, you can send it through the forums at this link.

Otherwise, due to the nature of what cleaning a project does, can you try regenerating the project files by right-clicking the .uproject file, compiling in Visual Studio, and then compiling through the engine?

Hey Matthew. I actually seemed to fix the issue. I am not sure the exact fix but it was a combination of deleting all intermediate files, symbols, PDBs and Regenerating the visual studio files by right clicking on the .uproject file. I am a bit hesitant to try it again on this project but I will see if I can get it to occur again. The only thing I know I did to cause the issue was to 1. Have a c++ project, Create some actors with blueprint children, and cleaned the project from inside visual studio.

I was unable to get it to occur using those steps unfortunately. Do you remember if the editor was open when you attempted to clean the project? Mine would fail as it was unable to delete the .dll that was being used by the editor. Please let me know if you have any more steps to provide.

Hi Matthew. I am unable to reproduce this now either. I have tried several times. Sorry. I do know the editor would have been open when I tried to clean the project.

had the same issue after cleaning my VS project. (vs 2015 communtiy version, unreal engine 4.10.2)

did not help:
right-click → generate visual studio files

did help:
deleting the whole “intermediate” folder from the project

thanks guys