Could Not Export Texture To .TGA But .COPY?

There Are Some Textures Assets In UE4 Content, When I Want To Export The Texture By RightClick It And Select “Asset Action - Export…”, The texture could only be saved as .copy & .t3d. But I want to export as .TGA format

The texture has been imported with PNG format

link text

I have the same issue

Same here, did you ever find a solution?

Have the same problem. BUMP

i just tried to add your file to my project to test with but for some reason it wont add it. when i try exporting one of my textures all i have to do to get .tga format is to use the file type drop down menu im in 4.17 though.

Same. For me, I’ve got that student work and I need to tidy it up - there are lots of unnecessary files, like BW textures for individual use as metallic, roughness, etc. Thing is, I CAN export tga files, when I’m exporting base color textures. But those BW maps I can’t export. Weird thing is, that those maps don’t have any specific flags or compression settings. DXT1, RGB, 8 bit per channel, World texture group, all that usual stuff.

The easiest way I found to handle this is to apply a material that uses the texture in question to a simple square with a 1:1 UV and in the simple squares mesh editor click on the Bake Material function and generate a material and textures, the newly created texture will export without any problems.

This answer absolutely worked! Thanks, AlienChrysalis. I posted a YouTube tutorial showing how I used your solution to solve my problem (I had also lost the original Substance file), crediting you for the answer in both the video and the description.

2 Likes

The format of the image asset must be RTF RGBA8 (or similar) to be able to export as TGA (as of UE4.22.1). If trying to export from the editor with the “create static texture” option on a Render Target, you can set this format in the Render Target settings. This may also affect runtime behavior.

For exporting images at runtime, what I ended up doing is getting the texture resource out of the target and reading pixels directly, in a TArray of FColor.

Hi its not letting me drag the material instance to convert it as a tga

1 Like

This is a very useful tip, a big thanks :heart_eyes:

EASY SOLVE: For me, I just had to go into PROJECT SETTINGS > search for DEFAULT RENDER TARGET FORMAT and switch that to RTF RGBA8 as [The_Regurgitator] said above. Once I did that, I could export to TARGA. Thank you!