Download

Could not determine the version of compiler WHY ?

I re installed windows for a third or second time and tried 4.6 and the master branch
each time I use GenerateProjectFiles I get Could not determine the version of compiler

I 've done this before and I had a stable linux compiling build
I follow the instructions here A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums to the letter but still Could not determine the version of compiler i tied the clang that I worked last time, and i tried re-downloading it.

What can be the reason, for this it is certainly not my writing of LINUX_ROOT and C:\CrossToolchain spelling . I tried different directories , i tried running the “setup” bat and without running the setup bat , NOTHING works. I tried compiling the engine then GenerateProjectFiles and a fresh new engine before compiling GenerateProjectFiles nothing works.

Any ideas what it might be needed for it to work, I tried like 5 different windows configurations but no luck , any libraries I should have? ( since I am compiling from source on a fresh install I could be missing some things. I remember that I had l4d2 and cs go running on the “cross compiling station” maybe they had some visual c++ redistributables I am missing?

It just seem so weird that I get the same error on 2 different machines, which both used to work just fine with this cross tool.

OMG :mad: the solution is so stupid …

1st run setup
2nd generate project files ( no linux var )
3rd I extract the clang content in C root so this is correct " LINUX_ROOT=C: oolchain "
4th I register the Env Var
5th run generate project files **AGAIN **

Hold up hold up.
The setup is fairly simple:
-Grab the source code of the engine (or binary release but I don’t know about that)
-Grab the Cross Toolchain
-Run the setup.bat on the toolchain
-Check the LINUX_ROOT value because sometimes it points to the parent folder and not the “toolchain” one.
-Compile the engine (or not if you haven’t got the source version)
-Generate project files or create a new project

Hello, I also had the same problem, and installing clang-3.5 package fixed the problem. (apt-get install clang3.5 for Debian)