Could not be compiled. Try rebuilding from source manually

I have been getting this error and I am not sure how to solve it. I have tried building it through my visual studio but I get a large amount of errors throughout it (around 110.) So far the steps I have taken are: uninstalling visual studio 2013 professional, installing visual studio community express. Reinstalling Unreal Engine 4.7.2, and finally installing Unreal Engine 4.6. So far none of this has worked. Any insight would be appreciated.

Some more context is needed here. Was this an existing project that used to compile, but stopped compiling when you upgraded to 4.7?

Completely fresh install. I am switching from unity

16gb RAM
Radeon 7850
Intel I5 3570k

Downloaded from the launcher

Can you share your system specs?

Also, are you building from the GitHub download, or from the launcher?

Have you done a getting started tutorial? Programming QuickStart

It sounds like maybe your Visual Studio isn’t being recognized. I had this issue a long time ago, but can’t remember how I fixed it. Someone else is going to need to jump on this thread.

I haven’t read the programming quick start yet but I have read the transition from unity to unreal engine. The problem occurs when I create the new project. I don’t have the chance to follow past step 1 in the programming quick start

Okay thanks,I will see what I can do to fix it in the mean time

There are older threads with Visual Studio not recognized. Sometimes it’s an installation order problem, sometimes the version of VisualStudio.

Hey brycem24-

Just to make sure I understand what’s happening, you are unable to create a new C++ project, is that correct? Are you able to create a blueprint project instead? Could you post the error message you get when trying to create the project?

Cheers

Doug Wilson

It should be solved. I uninstalled Visual Studio and instead of downloading from their website. I installed from the Project Creation tab.

Where do you install it from the project creation tab?

If I recall correctly, it just takes you to the microsoft Visual Studio Community Edition download page. You download the installer and go from there… It should be documented in the programming / installation docs.

Could you please brycem24 or Slayemin provide the link of this download? Because I also have troubles with creating a new proyect from C++ templates (however, I can correctly create a new proyect from Blueprints).
Thanks

If I’m not wrong, you have the same problem I had, and I finally got the solution.

Here is my own post with solution.

Hope it helps.

Hey jjmenezg93-

If you do not have Visual Studio when you try to create a new project it will prompt you to download it. If this doesn’t work for you please let us know exactly what happens when you try to create a new project.

I added an answer to this post with the solution I found to my problem. I had to inherit libraries and includes, as any other solution worked for me.

Thanks Doug Wilson

I will try

This is a really weired problem.

Did you got this error too.

I did something hacky and it worked when a scene of mine was getting the same error and would not open.

I just copied a new blank or generic “.uproject” file, the unreal project file, which is 1.kb, put it into the unreal projects directory with the one which would not open and that somehow became corrupt, gave it a name, and opened that. It opened the level just fine. Hack, without knowing how to program.