Corrupted uAsset by name only?

I’m getting a very odd corrupted uAsset and have no idea what’s going on and why this would happen.
The problem is when I load a scene which loads this asset (which I will call StairTop) the whole editor crashes. If I try to access the file (right click, or double click) the editor crashes. I’ve included the logs and dumps.

However this doesn’t happen on all the machines we have, we’ve had it on 3 out of 5. The ones which the asset works without issue is the one who created the uAsset (from a bsp->fbx). And then one more also has it working. The others crash on any access to this file.

So I started investigating. Rebuild the ddc (which is on a shared server).
cleared my intermediate and saved folders for both the engine and our project.
I commented out the ddc in DefaultEngine.ini
None of that worked.

I renamed the asset on a computer which could access it it, and then pushed it (we are using Git) and that worked. but my uasset was now called StairTopBroken. I fixed up the redirect to remove the old reference.
Everything is working fine. so I renamed it StairTop. and can still use the asset in a scene no problem. but if I close the editor and start it over again after. then any access to StairTop crashes the editor.

I also tried just changing the name of the file in explorer. which despite not changing the name in the content browser made it accessible again. As soon as I renamed it to StairTop and restarted the engine. Boom!
Creating another, new asset, and calling it with the problematic name will also crash the editor.

so i’m at a loss now, I don’t understand why it doesn’t happen to everybody, and I also don’t understand why it has to do with the actual filename.uasset which is on disk. I’ve referenced out the assets and used fix up redirects, but I’m getting that name creates some problems.

Thank you for all your help.
We’re using another name in the meantime :slight_smile:

UPDATE: I updated the engine to 4.11 (clean install), and rebuilt the project. I no longer have any issues.
I was originally at the 4.10 with latest hot fix from perforce

link text


Could you provide a bit more information about the asset?

  • What exactly is the asset? Is it a blueprint, static mesh, etc?
  • Did you import an .fbx to use with this asset?
  • Do you have any naming conflicts (i.e. another asset with the same name, even in another project?)
  • Can you reproduce this in a clean project with no additional content?

Also, looking at your log I’m seeing an error that mentions running out of memory: [2016.04.01-20.14.57:246][729]LogMemory:Warning: Freeing 33554432 bytes from backup pool to handle out of memory.

Is the asset that you are attempting to access extremely large?

Hi Sean, Thank you for taking the time to look into this.

I included the uasset in the zip if you want to look at it. it’s a static mesh 4m cubed module for a top section of a stair, very small asset.

  1. We created a BSP in an empty scene, placed it correctly.
  2. File->Export All to export the stairs to an FBX.
  3. Content Browser and did import to import this FBX.
  4. Then we double clicked on the asset to open the editor.
  5. In Static Mesh Settings we changed collision complexity to “Use Complex Collision as Simple.” So the collision wouldn’t be a cube but represent the stairs better.

There are no naming conflicts, This is the only project (our test project) which contains any asset with this name.

I created a new project and copied the uAsset into the structure and don’t have any problem accessing it. I had to copy paste in explorer because right click to migrate in Unreal would crash on that uAsset, or if I select multiple uAssets.

For the running out of memory, the only thing I can see is that it reads something wrong in the asset and tries to allocate a ridiculous amount of memory. because if I rename the file (in windows explorer) or in Unreal on another machine which opens the uAsset without any issues, I can access it, no problem at all.

I tried rebuilding the engine and my project with no success today also.

Thank you for your help.

Thank you for providing the additional information.

I could use a bit of clarification on step 3. Are you importing that FBX back into the same project, or is this a different project? You say you export the stairs, and then import them, and I wasn’t sure if you were importing them directly into the same project.

Once I have this information I can begin testing the issue to see if I can reproduce it on my end. Thank you.

Yes sorry, back into the same project.

Thank you for taking the time to look at it.

“UPDATE: I updated the engine to 4.11 (clean install), and rebuilt the project. I no longer have any issues. I was originally at the 4.10 with latest hot fix from perforce”

Are you still experiencing the issue? I just noticed this edit to the original question.

I tried to reproduce the issue following the steps you provided, but I was not able to do so.

The issue went away with a clean 4.11.
I had a 4.10 latest hotfix with symplygon installed.