Download

Correct measurement for animation from blender to unreal.

Hi there!

I was trying to do a ledge climb animation which was a success. However, i have encountered an accuracy issue that i cant solve. I have measured the precise measurement needed for the ledge climb in unreal and used that info for animation in blender ( for example ledge is 183cm high and distance to ledge is 18cm). I have animated the “ledge” in blender for the character to climb. Regardless of how much adjustment for accuracy, it seems like an impossible task. It always come up with difference in unreal aka grabbing something in thin air. To solve this i had to use actor location offset. But that alone was just a quick fix and not a permanent one, especially if i am going to have thousands of animations that require some form of accuracy and with their own variances in offset.

Has anyone tried animating with accuracy and solved it? Please share your secret recipe!

Well it’s not going to work as expected using a single take once the cycle has reached it limits. Usually this is referred to as ease in and ease out and blending into the ease in is simple enough but to ease out you will need to break out of the cycle and possibility included a two bone IK to hit the correct contact point.

If it’s the actual climbing velocity your having an issue with you could do the climb much easier as root motion as both velocity and direction is part of the animation data. Can’t use root motion you can tell the BP to ignore it and balance the velocity by connecting it to the velocity of the movement component.

Or

You could cheat and increase or decrease the animation scale rate so that the animations does not look like the player is swimming up the wall.

place the root on the ledge then have the animation play up on to the root location… if your do ledge shimmying just play the root side to side
thats the solution i did for it and it keep it clean looking

Thanks guys! I have solved it by using root motion. That was not without hair pulling on why there was “beam me up” anim at the root during the initial ledge climb animation. Found the solution to be not more than just disabling the Blend transition from one animation to the next. BlendSettings in the transition rule (in the main anim graph), settings duration to 0.0 and mode to linear.

I will keep in mind of the other solutions offered like the IK with ease out. Thank you!!!