Copy Paste And Duplication not working bug

This Appears to be extremely random, but sometimes or all the time copying pasting and duplicating do not work. Sometimes the short cuts don’t work, but the menu does. Sometimes the Cut will work, but will not paste. Sometimes the Duplication function works, other times IT will just flash the screen for a second, and nothing shows up. Sometimes when I restart my computer it acts normal. Sometimes it doesn’t work period and I just have to start ALL over on a secondary object/widget. The only time I haven’t had the Copy paste Duplication not working bug happen. Is in the content browser. That’s only thing that works correctly. Everything else works randomly.

PLEASE FIX! It’s driving me crazy!

I posted it in Linux because that’s the platform I’m on. I don’t know if it’s with the other versions

Does this problem occur on other projects, or just this one?

I would say all as I do too sometimes notice this, luckily I do not do this that often. I think that move also produces the same issue.

Yeah same thing here, some tricks and it works a bit better:

  • recompiled the engine (hmmm, dont know why, I think you can skip this but I did it)
  • disable to drag windows with the alt key in the desktop environment, it’s in most environment like unity and cinnamon
  • closed all other windows you have open (ie. a youtube full screen video on your secound screen is the worst thing you can do)
  • use nemo instead of nautilus
  • and try to paste in a text document. Mark some BP nodes or so, Ctrl+C, past it in a gedit document, see if something appears

But after all, it won’t be like on windows

I once had a really weird bug but upgrade it to 4.15 Preview had fixed it.
Of course that could give you new bugs, so you should create copies often, as well as create a copy once you open it in 4.15, but it does so automatically.

but not working in 4.15.1 version.

Just had this same issue all the way in 5.3… However I solved my issue by messing with the viewports placement. I dragged it out then placed it back in using those yellow border lines for snapping. Think Unreal gets stuck thinking that mouse is selecting a setting of some sort for viewports. Might work by closing viewports and opening them back up as well. The “have you turned it off and back on” solution appears to apply here.

1 Like

Hello, I’m having a problem where I can’t paste my custom-made blueprints. I can do it manually by rewriting them, but that’s too much work. I can paste to Notepad, I can paste to the search, but I can’t paste it in the blueprint area. The same issue occurs with objects. I try to take a MetaHuman head and paste it into the actor’s blueprint class so I can add it to a custom outfit, and it acts like I never even copied it. It’s only in UNREAL. I’m having this problem, and I tried to reinstall the engine, still doing the same thing. I even uninstalled my account and reinstalled it, thinking it was Epic Games. It is not. It’s on my end because no one else is having this problem, just me, and it’s annoying. I can’t work on anything till it’s fixed because I’m not rewriting code when I should be able to just copy and paste it.

I’ve been having this problem in 5.1

It seems that if I change functions access specifier from private to public, that solves the problem.

If I change to private, I cannot duplicate or copy and paste a function. I have to drag it from the My Blueprint panel.
If I change its access specifier to public, then I can copy and paste as normal.

Note that this is a function defined in the same blueprint class, but it acts as if it were a private function in a parent blueprint. So it seems to be a bug.