Cooked game resolution issues

Hello everyone,

I do not know if Unreal is bugged or i am missing something but for the love of me i cannot figure out why changing resolutions creates such a mess.

Let me further explain.My system has a 6000x1080 resolution.My game is set up for 1920x1080 in mind but i also support 1366x768 and 1024x 576 from my resolution menu.When i export my game and run it in my native resolution mentioned above it starts windowed.Now for the weird part.if i do not maximize the window and change the resolution to 1920x1080 f then everything becomes scaled down and deformed!

The game fills up the screen,the bars disappear but the actual game has huge borders around it.But if i maximize the window before i do the above and then choose 1920x1080 f then the game fills up the screen perfectly.Does anyone know what is going on?Is this normal behaviour?

NOTE:This happens even if i set my screen resolution to 1920x1080 ( all three monitors show the same picture)so i guess it has nothing to do with my initial resolution.I would also like to add that my game is a Paper2D project in case this matters.

Thank you.

Should I try to recreate it using an unreal project or this is something that other people have it as well and a future fix is on the way?

Howdy ,

Thank you for reporting this issue. Just going to need a bit more information from you before i begin looking into this issue. Would you be able to attach your project log files and your DXdiag to this post?

Have you been able to recreate this issue on a new template project? If so, could you provide any steps as to how I could recreate this issue internally? Any additional information on this issue would be greatly appreciated.

Thanks and have a great day!

Hi ,
I’m going to try and reproduce the issue this week.
In the mean time DXdiag would be great. Do you experience the same behavior with the examples?


Did you find the time to investigate the above problem?

I have done a bunch of testing with this and wasn’t able to reproduce the issue.
We don’t introduce black bars in unreal these are likely put there by a video card driver, which I suspect is causing the other problems also.
When the resolution is changed we adjust the FOV to compensate for the 16:9, 4:3 aspect ratios which is displayed using the width as the constant (so if you switch to 4:3 you will get extra information at the top and bottom of the screen).
If the video card or monitor driver is reporting different compatibility in regards to native resolutions this could be the problem, we use the native resolution to determine the native aspect ratio and then adjust that based on the desired resolution.
Not sure what hardware you are running or which versions couple of things to try are:
Disable GPU scaling.
For ATI this is under Flatscreen property in Catalist.
Nvidia it’s in Nvidia control panel → Display → Adjust desktop size and position → Scaling (also uncheck override the scaling mode set by games and programs)

Let me know if this changes anything.