Cook Failure Exitcode 3

From the research I’ve done so far, most users run into Exitcode 3 when dealing with individual assets that are of a significant file size, the only large assets I have are materials, usually pushing around 35MB each.

Other potential problems seemed to be the disabling of the Steam VR plugin, so I re-enabled that plugin, as well as the OculusVR plugin, just to be safe. No luck, each time I run into the same Exitcode 3, followed by Exitcode 25.

I’ve also been very explicit in keeping filepath lengths down to around 220 or lower.

I researched specifically to find the Line 739 error, and the only result I came up with was a pastebin link from someone else, with no discussion of the error.

I’ve attached the Full Cook Report here, and a few quick lines that I thought relevant below.

UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: Assertion failed: NULL != GeneratedClass [File:D:\Build++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\Engine\Private\Blueprint.cpp] [Line: 739]

UATHelper: Packaging (Windows (64-bit)): Took 59.3574986s to run UE4Editor-Cmd.exe, ExitCode=3

I’m not sure what other information to provide at this moment, this is really all I could find.

I had one corrupted Blueprint, which I didn’t realize wouldn’t throw a red error.

LogBlueprint: Warning:
FMemberReference::ResolveMember (Add
Ammo to actor once) bSelfContext ==
true, but no scope supplied!

That line gave away the error, I had an asset for adding ammo to players, but when I tried opening the file, it full on crashed the engine, so I deleted that file and all is well now.