Cook Failed due to Ustruct problem ( Unknown structure. )

MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2015.10.10-17.35.17:514][ 0]LogInit:Display: Warning/Error Summary
MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2015.10.10-17.35.17:514][ 0]LogInit:Display: ---------------------
MainFrameActions: Cooking (Windows): UE4Editor-Cmd: [2015.10.10-17.35.17:514][ 0]LogInit:Display: LogProperty:Error: UStructProperty::Serialize Loading: Property ‘StructProperty /Game/PC_System/FunctionLib/FunctionLib_AI.FunctionLib_AI_C:Convert RTSORder to PlannerOrder.CallFunc_GetButtonDataSheet_ButtonData’. Unknown structure.

Okay firstly. I have no idea why this is happening. I cannot reproduce it. But here are some information;

  1. Sometimes the cook work sometimes it doesn’t.

  2. The function library is using another function from function library which uses DataStructure from C++

  3. Sometimes I get load error , sometimes I don’t. it seems to be related to me rebuildling the code and blueprint. However , rebuilding everything does not work.

  4. This has happened more than once. It’s all related to one of the function library functions which actually does conversion for Data Table. All i need to do is to “Uncollapse” all these function. The cook would then work. But few days later another function using this Datastructure would pop in another error. This is causing me to slowly uncollapse all my function library.

This is IMO quite a severe problem. However I cannot reproduce it. But this is all the information I have. If there is a workaround for this. do let me know.

Hey Frozenfire-

I’m not sure I fully understand what your issue is and without any reproduction I don’t know where to begin my investigation. If possible could you provide your project and what you’re doing when the problem occurs so I can see the issue on my end?

Cheers

Doug Wilson

I am fairly confident the issue lies in the fact that FunctionLibrary isn’t allowing any output of an inherited structure(from C++) I use. Because whenever this happened , changing the output would absolutely fix it. However , I still seem to fail to create it in a brand new project as it only happens after a while ( possibly some changes to dependency )

Without a solid reproduction case I can’t isolate the problem or test if something has been fixed. If you’re able to find exact steps that reproduce this problem or are able to send me a copy of your project I can continue to investigate.

Okay right now i’m encountering this problem again.

I might be able to get a reproduction step if you can shed some light on how exactly these error occur.

My cook is now failing from this error. ( this is one out of the 3 similar error that is showing)

This is from Cook Log

LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/PC_Characters/1PArms/HeroFPP_1PArms_AnimBP.HeroFPP_1PArms_AnimBP_C:ExecuteUbergraph_HeroFPP_1PArms_AnimBP.CallFunc_GetDataTableRowFromName_OutRow'. Unknown structure.

This is the load error from Output Log

LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/PC_Characters/1PArms/HeroFPP_1PArms_AnimBP.HeroFPP_1PArms_AnimBP_C:ExecuteUbergraph_HeroFPP_1PArms_AnimBP.CallFunc_GetDataTableRowFromName_OutRow'. Unknown structure.

And this is the exact screenshot of the offending node. They’re all the same.

How is your DStruct_GameData_Weapon struct setup? Is this done in code or in another blueprint? I believe the structure used when setting up the data table is not being recognized. Has anything about the struct changed (name, number of variables, etc) since setting up the nodes? Let me know if you get the same error if you use a different struct in its place or try replacing the “Get Data Table Row” node and reassigning the struct to it.

It’s setup in Blueprint. I have had similar issue with structure set up in C++ as well. Yes I recently made some changes to the structure before the error occur. However , I have re-saved and recompile even the offending the blueprint , hit refresh all nodes.

However the strangest thing is that , there are other blueprint utilizing this exact setup without issues. There just too much randomness in this. It’s been resolved for me for now but the annoying thing is that , every few build , I’ll get the same problem. I tried everything i can to isolate the problem but still failed to. if it pops up again i’ll clean up the project and send you a zip.

Hey Frozenfire-

Since this issue seems to be sporadic I am going to mark this post as resolved for now. If you do encounter this again and are able to send a copy of your project you can comment to reopen the post and we will continue to investigate.

Cheers

Doug Wilson

Had the same error, all you have to do is recreate the Get Data Table Row node, select the DataTable from the dropdown menu, and reconnect it’s outputs, and try cooking the project again.

Had same error. Took a while to pin point it. Refreshing the node fixed it for me.