Converting existing 19.2 project to Studio Project fails

I have a project I’ve done some work in, converted it from 16 to 19.2. Works great, did a few days of level editing. Went to import a CAD model and realized the Studio tab was missing- went into plug-ins and, under Unreal Studio, there was a notification that I’d need to convert and re-load my project as an Unreal Studio project.

Clicked it, project closed, started loading, gets to 75% and now I get a popup that says

Plugin 'DatasmithCADImporter' failed to load because the module DatasmithCADImporter could not be loaded. There may be an operating system error or the module may not be properly set up.

Okay… obviously my first preference is to fix the issue so I can use the CAD importer, but I’d be happy enough being able to load my project without it! How do I fix or roll this back?

[USER=“9”]Stephen Ellis[/USER] might be able to sort this

i am seeing the same, epic support is also looking into it…


In Windows, navigate to the project’s folder location, find the .uproject file, and open it in Notepad or another text editor.

Find the “DatasmithCADImporter” plugin entry, and change the “Enabled” option to: false,

Save the file, and try loading the project again.

…We are investigating the cause of this issue.

thanks for your help, stephen!
i was able to get my project going by just disabling the CAD importer, the other two datasmith plugins load fine.


[USER=“9”]Stephen Ellis[/USER] So that was actually the first thing I tried before posting: I assumed that I’d find the reference there and could just comment it out and move on with life. But there’s no reference to the plugin there. I do have a line that says “Enterprise: true,” and flipping that bit worked.

Thanks for the tip, cheers!

So I’m guessing this is a known issue, but just in case: creating a new 19.2 project using the CAD visualizer template hits the same roadblock.

Can’t create any new DataSmith projects under 19.2 via the Unreal Studio tab, now even projects that worked before, that I’d created with the Unreal Studio tab under 4.19.1 fail to load, so I can’t even work on those.

4.18.3 shows the older build 17 of the plugin (which has all kinds of issues with loading Solidworks models- most models I throw at it “import” instantly, but all I get is a data file, no actual import, so that workflow is broken. v19 seemed to be working better, but now I can’t use it at all).

I don’t see any way to roll back or load an older builds of 4.19 (can’t install 4.19.0 or 1), 4.19.2 broke Unreal Studio as far as I can tell, and there’s no path back to a working solution. All progress is at a standstill from an end user perspective.

I don’t see a flood of similar comments, so perhaps it’s something local?

We aren’t experiencing any issue with UE 4.19.2 on our end, so one possibility is that you’ve had something change on your system that affects the prerequisites required for Unreal Studio.

You can try re-running the prerequisite installer from the UE4 installation directory:
\Epic Games\UE_4.19\Engine\Extras\Redist\en-us\UE4PrereqSetup_x64.exe

There are two installers, but x64 is the most commonly used. The installer may have you step through an uninstall first before it reinstalls.


Ran through uninstalling/reinstalling pre-reqs. No change. Is there anything else you could suggest? Is there a log file I can submit to someone? Does the plug-in have a stand-alone installer? Been using the same launcher since before UE4 was free, do I need to do a clean install of something else?

I’d recommend a clean install at this point. That should be the quickest way to being operational.

Uninstalling and reinstalling 19.2 from the launcher seems to have fixed the issue. Thanks, @kenpimentel and [USER=“9”]Stephen Ellis[/USER]