Converting a project to a newer version of ue

I have a project going in the 4.8 version of UE, but have some assets in 4.9 that I would like to use, also, some of the assets I use in the project are not upgraded to the 4.9 version, or 4.10 for that matter. I’ve seen people referring to upgrading (or converting) a project to a newer version. Anyone who could help me with a pointer on how to do this (or a step by step guide if possible)?

Hi Hardishane,

We have done our best to make this process as simple as possible. In the vast majority of cases, all you need to do is download the newer version of the Engine. Run the Editor to open the Project browser and find your project. It should look like it is grayed out, and may indicate the prior Engine version in the corner of the image for the project. Select the project and click the Open button (or double-click on the project). You will see a window appear asking how you want to convert the project. The recommendation is to always select the Open a copy option, as this will make a copy of the existing project and upgrade it to the new Engine version. That way if something goes wrong, the original project is still there for you to go back to

You may need to make some changes to the project at this point to get everything working in the new version of the Engine. If you have ever looked through the list of changes, fixes, and new features that accompany the release of a new Engine version, you will know that there are frequently extensive changes that could possibly affect your project. Ideally, there should be no new problems appearing, but as with any large piece of software there is a possibility that one of the updates has broken something for your project. Please let us know if this is the case.

Once you have verified that your project is working in the new version of the Engine, you can delete the original project. Also, keep in mind that it is often a good idea to upgrade your project one Engine version at a time. If your project is still using 4.8, don’t go straight to 4.10. Upgrade to 4.9 first, make sure everything is working, then upgrade to 4.10.

Tim

Handy tip, once you have done as Tim has said, from my experiences strangely the project may run ok, but you should open and recompile every blueprint to find any errors. Do this in 4.9 and again in 4.10.1 and it will save you allot of hastle.

So sorry how could I forget the most anoying bug ever. I have answered that question here

It’s a file system bug that has never been fix, and don’t look like it ever will.

Anyway if you wish to do a map check, click the little drop down arrow next to the build icon in the editor and you’ll see map check at the bottom

Followed the guidelines you gave me, but after recompiling all bp’s and doing a save all, I get the following message:

This map is using externally
referenced packages which won’t be
found when in a game and all
references will be broken. Perform a
map check for more details

I did not get that message when using 4.8, but as soon as I upgraded the project to 4.9 this message appears. I’m having difficulties with finding any kind of Map Check functionality… is this something that has to be done by manually tracing all packages?

Thanks guys… upgrading a project was really easy, and fixing the bug was a bit cumbersome but worked like a charm.

Up and running as intended at the moment. So… problem solved