Download

Controls won’t work after hitting “Play” in main menu

I made a SampleGame in UE4, and I had it packaged, but for some reason, when I hit play in the main menu, the level loads but the controls won’t work. They’ll work when you load it from the editor, or if it’s set to the default level when you package the game and have it where the main menu loads first? Nope.

Bumping thread.

Maybe add some logging to determine that the character is getting possessed.

I made it using the starter content, so there’s already a player character. It’s not that I can’t control the character at all, it’s just not working after hitting play in the menu. I can move it around and all that if I load the level elsewhere.

This is typically because the player controller doesn’t possess the character, hence your inputs go nowhere. If you are using Blueprints then add a Print node to your inputs, this should confirm that at least those are still fine.

I tried it but all I could get was a Print String function. Adding it didn’t work. It could only add text.

That’s fine, put that node in a few strategic locations to try find where the disconnect is, should help narrow down where the problem is.

Try the following on your level Begin event:
https://docs.unrealengine.com/en-us/Gameplay/HowTo/PossessPawns/Blueprints

Tried the pawn possession node and it didn’t work. I couldn’t select the Third-Person character I had from the menu, so I added one and then tried the pawn possession thing and it still didn’t work.

Bumping thread.

I have been made aware by MathewW from Epic Games, that a Project → Game Mode must be present… hope that helps.

I set it to Third-person Gamemode when I first started. GameModeOverride didn’t work and I can’t find “Project” nor “Game Mode” in the blueprint when I searched. I found “Get Game Mode” though.

I’m having a similar problem, but i didn’t write any BP’s except for an animated light.

When i PlayInEditor, Player Spawn defaults to an odd location, and i cannot move. UE4.22

Bumping thread.