Controlling a light function via matinee doesn't work

Hey Epic,
I created a light function to duplicate the functionality of barn doors on my lights - and I tried using a Float Material Parameter track in Matinee to control it (selected the material, made sure the name of the property was correct, etc.). This failed to work.

Then I tried the more disturbing blueprint route: creating a Dynamic Material Instance during construction - setting the light function material for the light to the created MID - and then on Event Tick setting the value of the material parameter to a variable named “LetterBoxAmount” I can mung this variable in the editor and the material parameter reacts appropriately (i.e. my light changes shape. As soon as I use Matinee to control the “LetterBoxAmount” variable - however - the material parameter doesn’t change. I can see the value of the variable changing to the animation curves in Matinee but the light function doesn’t seem to be receiving this input.

Hopefully that’s clear enough to understand. I’m using the 4.4 release (nothing custom). Let me know if I sucked at the bug report or if you have trouble repro-ing it.


Came in this morning and the whole thing magically started working even though we haven’t changed anything. Gonna go with computer voodoo.

I’m having the same problem in 4.9.1 now…
Light function, instance of it assigned to the lights, i add these lights to lighting group and change the parameters in vector material param track, but it does not change for some reason…

Anyone had/has the same problem?

Sorry for digging an old thread, but i thought it was a better idea than starting a new one

UE does not actually support light functions in material parameter track, not sure how opticol managed to make it work…
Added support for them, now everything works :slight_smile: