Controller Gamepad - Wrong behaviour

Hello everyone!

I have done some tests with an Xbox-360 USB Controller (Win7, UE 4.6), and it sends wrong values.

Steps to reproduce:

  • Set up a new Input: Gamepad Right/Left Stick […]
  • Log the value into the console, draw onto HUD, whatever

You’ll see that it sends values like a keyboard button: Only 1 or 0 (for a scale of 1).
However, it is supposed to provide a stepless input. (Values varying between 0 and 1 depending on the distance).

I found no way to fix this yet, but maybe epic’s team can fix it for 4.7.

Hi holzlag0r,

If you go into project settings>input and check the Axis Config section, there should be information on the deadzone, sensitivity, and exponent of each axis. You should be able to adjust your values here. Please let me know if this worked for you.

Hi ,
so I tried to adjust these seetings, and while I was doing that, I found out that what is called “Gamepad Right/Left Stick […]” is actually not an axis input - it’s an action input. The one I was looking for is called “Gamepad Right X”.

I think the naming is a little bit confusing, especially because there is not really a way to see whether the selected input is an axis or action event. Also, if you search for “stick”, you can only find the other one. So I guess this is not really a bug…

But thank’s anyway, I really appreciate the quick responses here on the answerhub. Also, I wasn’t aware of the axis config section, because it’s hidden by default - now I do, so thanks for that too!