Controller doesn't work in 'Play Selected viewport'

Hello! Me and my friend are working on a game that uses controller input with SourceTree Git repository. We used Dualshock 4 and XBOX 360 controllers for developing and it worked fine for a few weeks. But after one of the commits something happend with both of our UE4 engines.
We cannot use controllers anymore in any of projects, nor in the default engine project nor in the new created. We updated the version of the UE to 4.24, but the problem still was in there. What we checked at this point

  • Both of the controllers are recognised by Windows and are calibrated just fine, they also work in games. It seems like UE4 also knows about their existence since controller works in editor (!)
  • We thought that maybe the problem is that our Windows versions are different and it breaks something, my friend updated to my version of Windows and we both have 1909 now, but it didn’t actually help
  • We looked through logs - there is nothing connected with input that failes.
  • We passed our project folder to some of our friends so they can check if they also have this problem. And they don’t, controller works inside the ‘Play selected viewport’. They both used DS4 for that.
  • DS4’s touchpad is recognised as a mouse and works inside the game
  • ‘ShowDebug INPUT’ command didn’t show any sight of the controller and it shows DS’s touchpad as a mouse
  • We both have ‘xinput1_4.dll’

To sum up, UE4 sees the controllers and they work in the editor and do not work in the simulation (nor the ‘selected viewport’ or ‘PIE’). Something is wrong with our windows systems? Or with the UE4? We have no more ideas…

Try to reinstall Unreal Engine 4, if that don’t work, then try to make a new project and see if that will work with the controller or try an older version.

Thank you! It actually worked! It seems it was some strange UE4 bug, I am so happy it helped! :slight_smile:

So it was fixed through the engine reinstall. Some kind of a strange UE4 bug