Download

Controlled Foliage Placement

Hey there boys 'n girls,

just a quick question about the Foliage Painter.

Is there a way to restrict the area onto which the painted foliage is placed?
A bit more precise:
I am making/placing grass at the moment. My “garden” has a pool and a big square stone thing with a sitting area on it and the entire garden is surrounded by concrete walls. I now want to paint my grass and have it not overlap onto the sitting area or into the pool… I believe I had it figured out once, but I cannot recollect what I did there… Can I somehow restrict the foliage painter to a single object, as in the grass ground plane?

Pleas help!
Thanks already!

Greetz,
JayCox of on3studio

You can turn on and off what kind of geometry it should paint on, i think landscape, BSP or static meshes.
Another way that might be easier depending on what you’re doing is restricting it to the layer of the landscape if you’re using landscapes. This can be done by writing the name of the layer in the settings for each mesh in the foliage tool.

Well, I am only using static meshes for everything and I don’t feel like rebuilding my scene as a landscape… But I just found the Translucent button and maybe if I give the mesh a translucent material… I’ll try :wink: But thanks anyway! If you have any other suggestions I’d be more than happy to hear them!

EDIT:// Yeah, no… Translucent doesn’t work …

Normally it should work. Apply the “translucent” to the meshes which should be ignored and then it should just paint onto the parts which are normal meshes -> it’s also the easiest way for what you want to achieve :wink:

(but somehow you are not abel to paint onto meshes with “translucent” -> dont know if it’s a bug)

Ok, I tried that and I realised I was asking the wrong question:
If I paint the foliage meshes onto the object I want them to be on, it happens that if I get to close to another object the meshes Polygons/Edges/Vertecies overlap the over objects/meshes. For example around the pool, when I add the grass meshes close to the side of the pool, some polys go through the borders of the pool and “leak” into the pool… can I somehow stop that from happening?

As far as I know there is no efficent way how you can avoid that, but you could try to use a smaller brush or add something like a frame, which can be overlaped by the grass, to your pool. Otherwise place the meshes manually :slight_smile: