Download

Contains illegal characters? Crash

I tried to “Play in standalone game”, and Unreal crashes. It says something like "FilenameToLongPackageName failed to convert '…/…/…/…/…/…/… but the path contains illegal characters ‘.’

Can someone please advise how to solve this?

I had similar issues with long file and folder names once. I renamed them to something shorter and it worked.
I also had an issue where I couldn’t build, because the name of the project had an underscore and a number in it.
MyProjectName_01 would not build but MyProjectNameOne worked just fine.

Hope that helps.

Thanks for the reply. I have already renamed everything associated with this project to just a few characters. But still the same crash error.

The problem I think is when “Playing in standalone game”, Unreal would first attempt to save the project somewhere in c:\Users\xxx\AppData

Because the error message is like "FilenameToLongPackageName failed to convert ‘C:\Users\xxx\AppData\Local\xxx\Saved\Autosaves’ Attempt result was…/…/…/…/…/…/… but the path contains illegal characters ‘.’

But in Windows, the AppData is “Read-Only”. I tried to untick “Read-Only”, but the tick simply would not go away.

Or is there any way to prevent Unreal from having to access Appdata folder when “Play in standalone game”?